Power plug &lighter didn't work

Asked by Mar 20, 2017 at 10:56 AM about the 2000 Buick LeSabre Custom

Question type: General

Fuses under hood are good

2 Answers

1,390

Sometimes foreign material get into the plug and insulates the power point. Disconnect the battery and use a eraser or something like that to clean the contact, vacuum out the hole and see if it works.

7,155

Double check fuse. It's fuse #23 and it's a 20amp. If fuse is good, check for voltage at the plug. If fuse is good but still no power at the plug, check to make sure wires feeding the plug didn't come loose. If both wires, hot and ground are connected, trace wires back to fuse block, you may have a bad connection under fuse block

Your Answer

Buick LeSabre Experts

  • #1
    Tom Demyan
    Reputation
    2,220
  • #2
    John Saffrahn
    Reputation
    1,950
  • #3
    Austin Gaboda
    Reputation
    1,420
View All

Related Models For Sale

Used Buick Park Avenue
3 Great Deals out of 432 listings starting at $1,800
Used Buick Century
807 listings starting at $1,999
Used Chevrolet Impala
588 Great Deals out of 34,659 listings starting at $1,000
Used Buick Regal
177 Great Deals out of 9,915 listings starting at $3,500
Used Cadillac DeVille
1,666 listings starting at $1,995
Used Honda Accord
1,020 Great Deals out of 62,741 listings starting at $999
Used Lincoln Town Car
37 Great Deals out of 1,776 listings starting at $1,495
Used Toyota Camry
1,081 Great Deals out of 72,629 listings starting at $990
Used Mercury Grand Marquis
31 Great Deals out of 1,745 listings starting at $1,700
Used Chevrolet Malibu
1,230 Great Deals out of 78,092 listings starting at $1,500

Used Cars For Sale

2005 Buick LeSabre Custom For Sale
15 Great Deals out of 225 listings starting at $1,795

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.