Power plug &lighter didn't work

Asked by Mar 20, 2017 at 10:56 AM about the 2000 Buick LeSabre Custom Sedan FWD

Question type: General

Fuses under hood are good

2 Answers

2,660

Sometimes foreign material get into the plug and insulates the power point. Disconnect the battery and use a eraser or something like that to clean the contact, vacuum out the hole and see if it works.

9,905

Double check fuse. It's fuse #23 and it's a 20amp. If fuse is good, check for voltage at the plug. If fuse is good but still no power at the plug, check to make sure wires feeding the plug didn't come loose. If both wires, hot and ground are connected, trace wires back to fuse block, you may have a bad connection under fuse block

Your Answer:

Buick LeSabre Experts

  • #1
    John Saffrahn
    Reputation
    2,270
  • #2
    Austin Gaboda
    Reputation
    1,510
  • #3
    POPEYE99
    Reputation
    1,390
View All

Related Models For Sale

Used Buick Park Avenue
3 Great Deals out of 291 listings starting at $1,495
Used Buick Regal
74 Great Deals out of 3,462 listings starting at $1,995
Used Chevrolet Impala
551 Great Deals out of 25,673 listings starting at $790
Used Buick Century
579 listings
Used Honda Accord
745 Great Deals out of 97,282 listings starting at $750
Used Toyota Camry
1,011 Great Deals out of 70,933 listings starting at $1,137
Used Mercury Grand Marquis
20 Great Deals out of 1,296 listings starting at $1,250
Used Ford Taurus
268 Great Deals out of 16,242 listings starting at $986
Used Cadillac DeVille
1,283 listings starting at $999
Used Lincoln Town Car
26 Great Deals out of 1,394 listings starting at $1,600

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.