i have a 1991 pontiac trans am with a 5.7 tuned port engine with a transmission fault

Asked by Oct 14, 2013 at 02:30 AM

Question type: Maintenance & Repair

i have a 1991 pontiac trans am with a 5.7 tuned port engine with an automatic transmission. With the vehicle speed sensor disconnected the vehicle accelerates but wont shift out of gear. With the vehicle speed sensor connected the vehicle accelerated and then stalls out. the speedo which is electrical bounces up pass 120 mph mark. the transmission has been rebuilt. the pcm and cluster replaced. the wiring checks ok. any suggestions.

3 Answers

69,385

When you replaced the ECM did you transfer the original PROM to the new ECM? Is your "service engine soon" light on? If so, what code(s) do you have? HTH. -Jim

the prom was transferred. I changed the ECM twice to make sure it was not the ECM. there are no codes current or pending.

69,385

Have you tried substituting a known good vehicle speed sensor? Maybe yours is defective? -Jim

Your Answer

Pontiac

Looking for a Used Pontiac in your area?

CarGurus has 13,555 nationwide Pontiac listings starting at $1,200.

ZIP:

Pontiac Experts

  • #1
    tenspeed
    Reputation
    11,430
  • #2
    Tom Demyan
    Reputation
    9,220
  • #3
    Js08016
    Reputation
    8,340
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.