have a 2000 Buick regal ls, fuel pump is new and fuze box and relays are also new, my pump still runs after I shut it off, any idea on why??


Asked by Mar 12, 2015 at 08:04 AM

Question type: Maintenance & Repair

have many new parts and have been to a
few mechanics, it's a great car I'm hoping
someone can help me before I sell it from
frustration thank you

1 Answer


I would suspect the ignition switch.

Your Answer

Add photo

Related Questions

  • 2000 Buick Regal wont start 3 answers

    Ran fine all day running errands.After last stop for maybe 20 minutes, wont start.Everything else works, radio,lights, dash lights, bells etc.Took battery and had it charged, still wont start, even wi...

    2000 Buick Regal LSE


    Maintenance & Repair

  • what fuse # is the fuel pump relay on 2002 mercury sable 6 answers

    I'm trying to replace the fuel filter on a 2002 mercury sable. what number is the fuel pump relay ion the box under the hood?

    2002 Mercury Sable LS


    Maintenance & Repair

  • im having problems starting my 99 jetta for the past to days 7 answers

    it seems like its getting gas but no spark at all and it starts right up out of nowhere after i let it sit for a least 15 mins and it runs just fine until today when it just went off while driving, co...

    1999 Volkswagen Jetta New GL


    Maintenance & Repair

  • 1978 Chrysler New Yorker 440 Lean Burn System 22 answers

    My nefew's 440 ci New Yorker has 25,000 miles on her, inherited from his Grandfather. The car stopped running. The motor spins over, there is spark at the plug boot ends. The distributor has the si...

    1978 Chrysler New Yorker


    Maintenance & Repair


Search Maintenance & Repair Questions

Maintenance & Repair Experts

#1 Tom Demyan
Tom Demyan
Reputation 146,130
#2 FordNut
Reputation 101,010
#3 dandyoun
Reputation 82,470
View All