I have a 94 mustang GT 5.0 HO that I just got. Lots of mods, still trying to figure those out. My main question is my hazards work and wipers/brights I'm able to turn off and on but no blinkers. Help

25

Asked by Sep 07, 2014 at 04:19 AM

Question type: Maintenance & Repair

It also has an aftermarket steering
wheel but horn doesn't work either.
Any insight on what to look for would
be much appreciated. Thanks in
advance.

4 Answers

34,655

Have you checked the flashing unit it's self? I am almost sure that it has separate units for the 4 ways and the directionals.

246,855

If the Hazards work but no turn signals or the HVAC blower fan doesn't work, it is a loose connection or faulty ignition switch which is located on the lower end of the steering shaft. Check that out. It's a $15 part.

246,855

If it has an aftermarket steering wheel, the wire to the horn pad might not be hooked up properly.

25

I'll start with the wiring first. Seems the guy that modded the car apparently didn't like wires so much as to when I went to install a radio, I noticed the antenna wire had be cut off as well. Got allot of replacing to do and or fix.

Your Answer

Add photo

Related Questions

Shortcuts

Search Maintenance & Repair Questions

Maintenance & Repair Experts

#1 Tom Demyan
Tom Demyan
Reputation 174,840
#2 dandyoun
dandyoun
Reputation 93,520
#3 tennisshoes
tennisshoes
Reputation 76,080
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.