I have a 59 Sprite with a1275 cc engine. 3 of my gauges don't work - speedo, tach & gas gauge. I get the relationship betw the speedo & tach but why the gas gauge isn't working puzzles me.

Asked by Mar 13, 2015 at 06:08 PM about the Austin-Healey Sprite

Question type: Maintenance & Repair

2 Answers

10

The 1275 is not original to the 59 sprite. The speedo is cable driven off the transmission. In 59 the tach was mechanically driven by a cable from the generator. The 1275 has an alternator w/o the mechanical hookup for the tach. Most 1275 conversions use the electronic tach from later Sprites. As far as the gas gage goes, it is not uncommon for them to not work. It is an electrical troubleshooting problem. Find a sports car club in your area and join it. Their members have been through all this and can help you. Check out www.healeyclub.org and www.healey.org

1 of 1 people found this helpful.
115

Check the sending unit for the fuel tank. Mine was bad and I had to pull the tank and replace it as it sits on top of it. Could also be the wiring connection to the unit - unfortunately it is a blade tupe connection on the sending unit - so tank has to be pulled.....Not a very difficult job - got a newunit from Victoria British for about $40.

Your Answer

Add photo

Related Questions

Search Austin-Healey Sprite Questions

Austin-Healey Sprite Experts

#1 Tom Demyan
Tom Demyan
Reputation 20
#1 Neil Williams
Neil Williams
Reputation 20
#1 Hinz
Hinz
Reputation 20
View All

Related Models For Sale

Used Porsche 911
106 Great Deals out of 4,436 listings starting at $10,999
Used Mazda MX-5 Miata
78 Great Deals out of 3,926 listings starting at $1,800
Used Ford F-150
2,114 Great Deals out of 192,315 listings starting at $290

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.