My 93 GMC truck it won't start unless I unplug map sensor vacuum hose when I try it to plug it back up truck turns off its starts like fludding its smells a lot off gas. But with out it it stays runing

Martin Centeno

Asked by Dec 02, 2014 at 12:44 AM about the 1987 GMC C/K 10

Question type: Maintenance & Repair

1 Answer


Sounds like the result your sensor gives to your ECM is incorrect for the altitude. Fuel system pressures and volume tests should be run and a different sensor must be tried. Basic tune up check and spark parts should be inspected for wear and tracking issues. Sensor codes should be run from the ecm test link connector. Return with results to each of these tests and use A/C Delco parts where available. Since your vehicle exceeds 20 years, consult your maintenance records about tune up and fuel system repairs to date.

Your Answer

Add photo

Related Questions

Search GMC C/K 10 Questions

GMC C/K 10 Experts

#1 FordNut
Reputation 80
#2 tennisshoes
Reputation 30
#3 gearheadnard321
Reputation 20
View All

Related Models For Sale

Used GMC Sierra 1500"
1,026 Great Deals out of 56,923 listings starting at $2,300
Used Ford F-150"
3,257 Great Deals out of 216,652 listings starting at $1,500
Used Chevrolet C/K 1500"
1,138 listings starting at $2,400
Used Ford F-250"
609 listings starting at $3,995
Used GMC Sierra"
39 listings
Used Ford F-100"
167 listings
Used Chevrolet C/K 2500"
287 listings starting at $1,995
Used Chevrolet S-10"
13 Great Deals out of 1,811 listings starting at $1,749