All Car Questions

  • Newest
  • Recently Active
  • Unanswered
tanteconny
0

On My 3rd Alternator

I have a 2005 Ford focus. In 2010 I drove through alot of rain water. My car lost power and I had to have by alternator replaced.Since then I have gone through 3 more alternators. symptoms: I commut...

68 views with 1 answer (last answer about a year ago)
wrencher903
20

What Component Operates The Egr Solenoid

ive got a 92 mighty max 4cyl 2wd. i have no vaccuum to egr. when i probe the first wire on the harness plug it has power, when i ck the second wire it also has power but the vacuum begins to work o...

253 views with 12 answers (last answer about a year ago)
LisaAC
0

My Wiper Fluid Isn't Coming Out. Yes, I Filled It! Is There A Fuse For This...

The back wiper seems to do the same- wipes but no fluid comes. Blown pump?

1,585 views with 3 answers (last answer about a year ago)
konniw
0

Put Battery In Wrong

I put my battery in wrong and i blew the fuse 100A and now my car does not start at all. i replaced the battery put in the right way and now lights come on and they would not before i replaced the 100...

269 views with 4 answers (last answer about a year ago)
partypooper476
0

How Wide Is The Sunroof On A 1988 Acura Legend Ls 4 Door

i want to buy a wind deflector but i dont want to buy one that isnt wide enough

31 views with 1 answer (last answer about a year ago)
tbears
30

My Car Runs Fine In Park, When You Put It In Gear It Stalls Out. What Coul...

When my car is in park it runs fine. As soon as you put it in gear it stalls out.

6,047 views with 17 answers (last answer 4 months ago)
resco1970
0

I Have A 1992 Dodge Caravan . I Want To How Do I Check If I Need Transmissi...

106 views with 3 answers (last answer about a year ago)
artierand
0

I Want To Buy From Private Party

75 views with 1 answer (last answer about a year ago)
composergodsglory
0

My Car Will Not Start Unless Foot Is Depressed On Gas Pedal. In Combination...

2002 buick century. Recently back fired, replaced the IAC, fully cleaned the throttle body, all injectors are working, new spark plug wires, new fuel filter, fuel lines. It is running without a m...

401 views with 3 answers (last answer about a year ago)
Tony Wigz
15

Installed New Tranny, Jetta Wont Start

Bought the car, was a lemon with a bad transmission.. Was at too much of a loss to buy a new car so I replaced it. Drove the car home, during the car ride the check battery light flickered on a few ti...

138 views with 6 answers (last answer about a year ago)
Cindy Swindal
0

2003 Mit Outlander Garage Said Probably Blown Head Gasket Might Need Anothe...

how to get reeliablabe estitame on 2003 mit outlander how much if its just a blown head gasket

116 views with 1 answer (last answer about a year ago)
96Bonneville
0

Can I Replace The Firewall Covers Of The Heater Core And Heater Fan? Both B...

Can those 2 "covers" that are part of the firewall be purchased somewhere? I have a 96 Bonneville I bought new in 96 with 110,000 & I still love it. It is pretty much mint condition.

108 views with 1 answer (last answer about a year ago)
chazzer1
0

I Think You Misunderstood What I'm Looking For Judge_roy.. I Want To Sit In...

49 views with 7 answers (last answer about a year ago)
ckbradley
0

After Lots Of Replaced Part, Still Running Rough

Recently my 2001 Sable indicated a misfire on 2 and 6 and P1311 - Lack of Heated Oxygen Sensor Bank 1. I replaced the spark plugs and both O2 sensors. Then I was getting a misfire on 1 and 2 and the...

492 views with 3 answers (last answer about a year ago)
bigrick1980
0

I Have A 1994 Toyota Camry `and My Speedometer Keeps Burning Behind The Clu...

26 views with 2 answers (last answer about a year ago)
oitsusan
0

I Need To Find A Business That Can Clean Underneath My Volkswagon Van.

Along with the cleaning, I need some rust preventive done.

29 views with 2 answers (last answer about a year ago)
rfo1956
0

Can I Use A 2.5 Motor From A 2000 Forester With A Automatic Transmission ,i...

36 views with 2 answers (last answer about a year ago)
abelinc65
0

My 02 Lincoln Ls Will Run Very Rough After Starting

The previous owner changed all the plugs, all the coils, the intake gasket. The initial problem was it overheated. But I thought they shut themselves off to avoid damage.

146 views with 3 answers (last answer about a year ago)

Favorite Topics

Track new questions that interest you

or

Sign in

Ask a Question

CarGurus Experts

#1 Tom Demyan
Tom Demyan
Reputation 136,935
#2 dandyoun
dandyoun
Reputation 76,615
#3 tenspeed
tenspeed
Reputation 68,335
#4 FordNut
FordNut
Reputation 51,025
#5 tennisshoes
tennisshoes
Reputation 40,315
View All