All Car Questions

  • Newest
  • Recently Active
  • Unanswered
Kevin Baluha
0

I Have A 2000 Montero Sport I Had A Friend Do An Engine Swap - All Is Runni...

2000 montero sport 4x4 i had a friend do an engine swap - all is running but AT will not move the vehicle - dash lights indicate its shifting. AT Fluid seems slightly above the hi mark. What do I do...

265 views with 6 answers (last answer about a year ago)
Greg Beyerlein
555

5 Unique Check Engine Codes (12 Codes, Total) --- Transmission Not Getting ...

I have a 2009 Chevy Avalanche LT-2 (4WD), purchased in 2012. The check engine light came on, had it scanned and they told me it was a loose / faulty gas cap. So, I changed the gas cap, light went ...

702 views with 3 answers (last answer about a year ago)
Jermaine Frazier
0

I Have A 88 Camaro And I Can't Get Fuel To The Throttle Body. I've Changed...

I put the car in the shop. They did get it running but that was only long enough for them to rob me of $1200. I drove it about 30 miles and it was sputtering and kinda stalling. The next day it wa...

69 views with 4 answers (last answer about a year ago)
georgemo
0

How Do I Replace The Turn Signal Bulb In A 2007 Mariner. There Are 2 Scre...

211 views with 1 answer (last answer about a year ago)
RichieR
0

I Have A 1989 C1500 Truck And My Wipers Keep Running After I Turn Them Off ...

21 views with 1 answer (last answer about a year ago)
Lorian
0

I Have A 93 Mazda Miata And The Ac/ Heat Will Not Come On. I Got The Fuses ...

One time i had accidentally left the knob turned on 4 and about 2 minuets later it started to smoke. With winter coming i really need the heat can anyone please help.

48 views with 4 answers (last answer about a year ago)
Michael Acocello
0

I Can't Find Which Fuse Is For My Turn Signals

my turn signals slowly went out, started issues on Saturday and stopped working wed. I've changed out a few fuses trying to guess which one is for the turn signals and still haven't been able to fi...

1,150 views with 1 answer (last answer about a year ago)
Cindy Norberg
0

Will A 1993 Nissan Pick Up Motor Fit In A 1997 Nissan Pick Up?

Both trucks are hard bodies but the 1993 is not a 4x4 , the 1997 is a 4x4

154 views with 2 answers (last answer about a year ago)
Abdul Halim Burnham
0

Car Gave Me A Light Show From Battery Post As I Attempted To Connect Them T...

From starter now won't turn over..what could it be and how do I get it started. I have electrical power but won't start

4 views with 1 answer (last answer about a year ago)
sirbensr
0

No Heat In My 91 Sedan. Replaced Heater Core, Thermostat, Radiator, Overflo...

114 views with 2 answers (last answer about a year ago)
Inventor14
5

Http://www.zvonkop.tk

7 views with 1 answer (last answer about a year ago)
darkiss4428
0

87 Chevy Astro Power Issue

the battery died, put a new one in it cramked and ran fine tested the altinator its fine drove it home and cut it off and now have no power at all even with new battery / different batteries

51 views with 1 answer (last answer about a year ago)
bobbeeman
0

Engine Misses During Acceleration

The engine starts well and runs smoothly for a while then starts missing. If I turn the engine off and restart it may or may not miss. I replaced the plugs. Not them.

165 views with 2 answers (last answer about a year ago)
Fain7171
0

Help With Diagnosis-ford F150 (1994)

I have a Ford F-150 (1994). The battery indicator light (new battery so this I would assume not the issue) came on and I lost power steering. As I was returning home the Check Engine light ca...

2 views with 1 answer (last answer about a year ago)
danbarnett
0

99 C5, Take Out Cat Converter Or Hollow It Out.... Helpful Or Harmful?????

31 views with 4 answers (last answer about a year ago)
rancornett01
0

My Blower Motor Only Works Sometimes, Works Well, In All Speeds When It Wor...

works in all speeds when it works, does nothing in any speed when it doesn't work

175 views with 1 answer (last answer about a year ago)
Scout61
0

2001 Dodge 1500, 5.9l

wouldn't start and diagnosed with bad crank sensor and bad processor, flashed the processor and truck is running. Now the doggone thing "hiccups" (misses or at least sounds like it) during idle and wh...

75 views with 3 answers (last answer about a year ago)
Paul McGiffen
0

Searched For: Fue Leak On Top Of Gas Tank - Steel Lines On Tank To Filter A...

130 views with 1 answer (last answer about a year ago)
wolf99
0

I Have 1998 Plymouth Breeze 2.0

I heav replaced that batter and alternator And battery and it still won't hold a charge I shut it off and now it dead again anyone know y this is

24 views with 1 answer (last answer about a year ago)
vmonroe1
0

Tried To Start My Car, No Noise No Crank. Light, And Radio Comes On. What C...

78 views with 3 answers (last answer about a year ago)

Favorite Topics

Track new questions that interest you

or

Sign in

CarGurus Experts

#1 Tom Demyan
Tom Demyan
Reputation 178,935
#2 FordNut
FordNut
Reputation 127,855
#3 dandyoun
dandyoun
Reputation 91,555
#4 tenspeed
tenspeed
Reputation 81,135
#5 tennisshoes
tennisshoes
Reputation 62,015
View All