We placed my fuel filter and fuel pump

kufan4life
15

Asked by kufan4life Aug 20, 2013 at 03:58 PM about the 2000 Chevrolet Blazer 4 Dr LS 4WD SUV

Question type: Maintenance & Repair

Now it's hesitating to start most times.. have to prime it and even pump the gas pedal to
get it to start... did we forget to connect something?

4 Answers

tennisshoes
18,335

Have you checked the pressure of the new pump?

Tom Demyan
82,965

Install the fuel filter correctly? They flow only one way. Check the arrow on the filter. Should be pointing away from the tank.

kufan4life
15

yes he put that in a few weeks before the fuel pump was replaced... fuel pump had been on its last leg.. then it finally quit Aug 3rd on my way home...we had a problem getting the return fuel line though... I couldn't afford $121 at the dealer so we got one at the parts store (repair kit) and he made one.. first they sold us the wrong size.. then we got wise and took the old pump with us to match lol... it starts after priming the fuel pump and pumping a few times... I'm beyond frustrated

kufan4life
15

no tennisshoes we didn't check that... I might sound dumb, but how do you check that?

1 out of 1 people think this is helpful.

Your Answer

Related Questions

Blazer
Looking for a Used Blazer in your area?
CarGurus has 2,560 nationwide Blazer listings starting at $2,000.
ZIP:

Search Chevrolet Blazer Questions

Chevrolet Blazer Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 480
#2 dandyoun
dandyoun
Reputation 440
#3 yetilikesbeer
yetilikesbeer
Reputation 390
View All