1990 560 sel will not start. Not getting fuel to engine

gregburg1
0

Asked by gregburg1 Sep 06, 2007 at 02:44 AM about the 1990 Mercedes-Benz 560-Class 4 Dr 560SEL Sedan

Question type: Maintenance & Repair

I have a 1990 560 sel. Vehicle  wil not start now. Not getting fuel to engine. I pour gas into intake and it will run. Fuel pumps or relay fuse need replacing??

5 Answers

dvigano
10,175

Hi gregburg1, This could be your fuel pump, fuel filter or fuel regulator. I would also check (just to be sure) that you don't have any "crimped" fuel lines between the tank and the fuel rail. Good luck!

omegaman99
150

Fuel pump or fuel pump relay-crank engine,see if pump buzzes.If pump inop,see if current comes.if no juice,relay faulty(common problem)

2 out of 2 people think this is helpful.
Mike Blomquist
115

Definitely sounds like the fuel pump or relay. Unless you have very high mileage or you have been putting crapy gas in it, i would put my money on the relay. Either way it is not to hard to fix.

1 out of 1 people think this is helpful.
Werner Watzdorf
75

Can you hear the fuel pump running - by right hand side rear wheel? if yes, change fuel filter adjacent to pump, if not check relay- square black box approx 60mm by 30mm right hand side engine bay close to fire wall. Come back with your findings and we'll help further...

7 out of 7 people think this is helpful.
mrnatural
60

my 5600 has same problem ive changed pump relay and gas comes out of regulator but still wont start

6 out of 6 people think this is helpful.

Your Answer

Add photo

Related Questions

560-Class
Looking for a Used 560-Class in your area?
CarGurus has 147 nationwide 560-Class listings starting at $2,995.
ZIP:

Search Mercedes-Benz 560-Class Questions

Mercedes-Benz 560-Class Experts

#1 Mick Stewart
Mick Stewart
Reputation 80
#2 bobkat
bobkat
Reputation 70
#2 Werner Watzdorf
Werner Watzdorf
Reputation 70
View All