Sign in | Register | My account |

99 with electrical probs, got rained on, one cylinder not firing...

stuck
0

Asked by stuck Nov 30, 2011 at 08:36 PM about the 1999 Hyundai Tiburon

Question type: Maintenance & Repair

passed insp. ran 2 hrs on long trip, parked for three days in heavy rain, 189,000 mi on engine, started 2 days later, one cylinder won`t fire, smooths out @ 3,000 rpms, engine light flashes, etc. plugs looked fine when pulled. is this a clogged injector?

3 Answers

Wynand Beer
95

You could try to reset the cars ECU first to see if the engine light error clears by disconnecting one battery terminal and pressing on the brake pedal to drain the power from the system. Then wait about 30min and re-connect the terminal. Also check the wires from the plug to the coil pack. It could just be a dead plug.

James Warner
1,490

did any plugs have carbon tracking on them? sometimes finding any arc marks on these plug wires can be difficult to see as they are on the inside of the wire itself. try running the engine and wetting the coil and wires with a spray bottle of water. this should let you find your misfire

biggdog462001
285

open hood at night time and start engine, you will most likley see little blue sparks jumping around , in short put a new set of spark plug wires and a new set of spark plugs as when spark plugs get wet with liquid fuel, they may look good but most of the time , you are just wasting time, change plugs at same time as wires, and do it one wire at a time, so you dont mess up the firing order. the tip on this one is the heavy rain!

Your Answer

Related Questions

Tiburon
Looking for a Used Tiburon in your area?
CarGurus has 803 nationwide Tiburon listings starting at $1,587.
ZIP:

Search Hyundai Tiburon Questions

Hyundai Tiburon Experts

#1 kristinaklc
kristinaklc
Reputation 190
#2 California_Kid
California_Kid
Reputation 160
#3 wtrujillo_77
wtrujillo_77
Reputation 130
View All