Sign in | Register | My account |

pcm ..no communication

jamiec
0

Asked by jamiec Nov 01, 2011 at 09:21 PM about the 1997 Chrysler Intrepid

Question type: Maintenance & Repair

pcm wasn't communicating with diacnostics...replaced it and still not reading. replaced the wires as well..any ideas?

17 Answers

Michael Mierzejewski
1,700

dumb question but did you check the fuse for the DLC? ive had them go bad before.

1 out of 1 people think this is helpful.
jamiec
0

i haven't but i sure hope canadian tire did since i paid for diagnostics. where is it located so i can check it?

Michael Mierzejewski
1,700

probably in the interior fuse box, if it has one. check the map on the fuse box cover for anything that says DLC. DLC = data link connector, which is the diasgnostic port

1 out of 1 people think this is helpful.
jamiec
0

thanks. i'll give it a go. any other ideas in case that doesn't work?

Michael Mierzejewski
1,700

if youve already replaced the pcm and the DLC wiring, theres no reason it shouldnt work.

jamiec
0

thanks so much. very helpful. hope it'll work :)

Michael Mierzejewski
1,700

is there power at the DLC? meaning when you plug the scan tool in, does it power up the tool?

1 out of 1 people think this is helpful.
jamiec
0

yup. yhey even ran a seperate wire to make sure there wasnt a short . they're absolutely lost. my only hope was to see if anyone else had this problem

Michael Mierzejewski
1,700

ive seen this before with a lot of cars, but its never been the same reason twice, or easy to fix.

jamiec
0

don't know if this has anything to do with it but code 21 (speed control solenoid ) or somethinb like that pops up too

papa
Not Active

in a Chysler when the scanner wont comunicate,the computer is bad,replace it,a used one will work.

1 out of 1 people think this is helpful.
jamiec
0

i replaced it today. it still won't work

papa
Not Active

make sure the ECM fuse is not blown,and the pcm fuse,also check the ignition crank fuse.

jamiec
0

is the ecm fuse the same as the dcl fuse

papa
Not Active

no.it should be in the fuse box under hood,all of them.

jamiec
0

ok. i'll have to take a look in the am. thanks :)

Tiredofmyintrepid
10

I'm having the same problem. Replaced cam sensor, ECM, wiring harness and still p340 code keeps coming up. Sometimes car won't start. I don't know what else to do. Any solutions? I have a 03 Chrysler intrepid (not dodge)

1 out of 1 people think this is helpful.

Your Answer

Related Questions

Intrepid
Looking for a Used Intrepid in your area?
CarGurus has 8 nationwide Intrepid listings starting at $2,495.
ZIP:

Search Chrysler Intrepid Questions

Chrysler Intrepid Experts

#1 Michael Mierzejewski
Michael Mierzejewski
Reputation 30
#2 Trebor66
Trebor66
Reputation 20
#3 Tiredofmyintrepid
Tiredofmyintrepid
Reputation 10
View All