All Car Questions

  • Newest
  • Recently Active
  • Unanswered
DLReiter
0

My 2003 Chevy Trailblazer Wouldn't Turn Off.

I was able to turn the ignition to the off position, take out the key and then noticed that it was still running, I couldn't get it to turn off. I then drove about 5-7 miles and then it powered down, ...

13 views with 1 answer (last answer about a year ago)
queendaddy
0

Battery Light On Power Steering Not Working

Battery light came on after driving for a while, and the power steering stop working at the same time, can someone help me figure out what the problem is?

69 views with 2 answers (last answer about a year ago)
ladyfox
0

How Do You Fix The Ignition From Sticking And Not Turning In A 2007 Kia Opt...

I tried to start my car the other day and the key would not turn at all. I tried to move the steering wheel it did not work. I made sure that the car was in the park position all the way it was. I kee...

97 views with 1 answer (last answer about a year ago)
Kuhnible
0

2002 Aztec All Wheel Drive. Shudders Instead Accelerates, Does Not Like To ...

It gets worse after the car warms up and is useing a lot of fuel.

37 views with 1 answer (last answer about a year ago)
1malisa1
0

I Have A 98 Chevy Lumina And The Air Takes About Ten Minutes To Get Cold Wh...

3 views with 1 answer (last answer about a year ago)
Mystik Love
0

My Boyfriend Ran My 2005 Mustang Thru Deep Water Now It Leaking Oil What Di...

36 views with 3 answers (last answer about a year ago)
norton30531
0

06 Pt Cruser Is Overheating. Instaleed New Fan Module Ran Great For Two Wee...

new fan module, ran ok first two weeks then same ole crap. according to repait shop no pressure leaks, buy no sign of leaks. have to ad coolant every other day or so.

15 views with 1 answer (last answer about a year ago)
fam517
10

The Service "servie Engine Soon" Warning Light Has Come On In My 2004 Mercu...

I have a 2004 V8 Mercury mountaineer with about 11700 miles on it. My "service engine soon" light came on and my local dealer told me that my "PCM" needs to be replaced and wants to charge me over $...

193 views with 3 answers (last answer about a year ago)
cttrkdrv5
20

My 2003 Jetta 2.0 Ran Fine Yesterday Went Out To Start It This Morning And ...

My 2003 Volkswagen jette started and ran fine yesterday went out this morning and it wouldn't start or even turn over and ones help would be greatly appreciated today

114 views with 6 answers (last answer about a year ago)
Reepon
0

I Own A Honda Crv 2004 A/t. My Problem Is* When I Accelerate After It Hits ...

I own a Honda CRV 2004 A/T 2.2 VVTi FWD . Problem is : 1. When I accelerate after it hits 80 KPH the car does not shift to the next gear 2. if I accelerate then only the rpm increases but not the spe...

72 views with 1 answer (last answer about a year ago)
Stephanie Raymos
25

Jerking Only When Going 45-55 Mph.

I have a 95 Ford Contour. It runs fine and there isn't any warning lights on. It shifts a little rough but nothing to serious. It will start jerking/surging slightly when I go over 45 and up to 55 m...

121 views with 3 answers (last answer about a year ago)
treybev
0

Was Driving And Heard A Loud Whining Sound And Battery Light Came On Light ...

125 views with 3 answers (last answer about a year ago)
leighcin
0

Can I Yow A 2013 Jeep Patriot Manual Tranny!

Want a jeep I can tow behind motorhome, found a patriot, can it bee flat towed?

125 views with 3 answers (last answer about a year ago)
Susan Plasencia Larsen
0

My Key Is Stuck In The Ignition, And It Won't Start. The Battery Test Wel...

115 views with 1 answer (last answer about a year ago)
April Winslow Newkirk
0

I Have A 95 Ford F150 Xlt With 5.0 The Tranny Went Out And I Have Gotten Th...

8 views with 1 answer (last answer about a year ago)
at1234
15

05 Sienna Passenger Power Door Not Closing

Greetings. I have an 05 Sienna that has developed a problem with the passenger side power door. It opens fine, but when closing it gets to the very end, then re-opens. If I tug on the door a little ...

53 views with 2 answers (last answer about a year ago)
kharton
0

Engine 6.0

Oil in the antifreeze .

20 views with 3 answers (last answer about a year ago)
pontiacnut62
0

Locking Vacuum Pump Stoped Working And Top Of Case Melting

I had a bad locking vacuum pump I replaced it with a used one it worked for about a month then quit this case was melted around the top to possible another bad pump or something else John

45 views with 3 answers (last answer about a year ago)
Tyler Medine
0

Where Is The Cooling Fan Switch?

Both fans on radiator not working.

104 views with 9 answers (last answer about a year ago)
Bunghole
95

Hi, I Am Your Expert On Non Mech Issues For Honda Insights 2010-2015

Ask away

34 views with 4 answers (last answer about a year ago)

Favorite Topics

Track new questions that interest you

or

Sign in

CarGurus Experts

#1 Tom Demyan
Tom Demyan
Reputation 200,515
#2 FordNut
FordNut
Reputation 138,075
#3 dandyoun
dandyoun
Reputation 98,395
#4 tenspeed
tenspeed
Reputation 87,095
#5 joemom
joemom
Reputation 74,585
View All