2000 sunfire 2.2l no power and shakes but runs good in park

30

Asked by Mar 22, 2011 at 03:50 PM about the 2000 Pontiac Sunfire SE

Question type: Maintenance & Repair

my sunfire started shaking and misfiring last week the cat was glowing red so i changed it and also changed the wires and plugs now it runs goodin park but when i took it out the driveway and down the raod i have no power and the car is shifting hard and sounds like it is going to stall but it does not stall could it be something besides motor or trans?

2 Answers

30

well if anyone else has this problem it was my coil pack 1 and 4 were not firing

2 of 2 people found this helpful.
60

Same problem Woodroffe, Replaced the coil pack, the plugs and the wires and still have the same problem... Can clear all codes and it will idle fine in Park, but once I put it into gear, it starts all over and I keep getting error Code P0300 (Misfire) I am stumped...

6 of 6 people found this helpful.

Your Answer

Pontiac Sunfire Experts

  • #1
    John Saffrahn
    Reputation
    2,790
  • #2
    Joeyadams
    Reputation
    1,340
  • #3
    Warren0007
    Reputation
    1,250
View All

Related Models For Sale

Used Pontiac Firebird
11 Great Deals out of 776 listings starting at $4,300
Used Pontiac Grand Prix
32 Great Deals out of 2,705 listings starting at $1,491
Used Pontiac Grand Am
1,065 listings starting at $1,899
Used Honda CR-V
803 Great Deals out of 53,789 listings starting at $1,750
Used Toyota Corolla
880 Great Deals out of 56,048 listings starting at $1,488
Used Honda Accord
1,092 Great Deals out of 60,890 listings starting at $1,099
Used Chevrolet Camaro
409 Great Deals out of 30,660 listings starting at $3,550

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.