2000 Firebird with automatic tans wont go into park

5

Asked by May 28, 2013 at 12:27 PM about the 2000 Pontiac Firebird Base

Question type: General

1 Answer

1,035

Sounds like a linkage problem. Did you check to see if your shift cable is bad?

1 of 1 people found this helpful.

Your Answer

Pontiac Firebird Experts

  • #1
    Samuel Moore
    Reputation
    980
  • #2
    dandyoun
    Reputation
    810
  • #3
    John Saffrahn
    Reputation
    700
View All

Related Models For Sale

Used Chevrolet Camaro
416 Great Deals out of 30,919 listings starting at $3,550
Used Ford Mustang
724 Great Deals out of 38,098 listings starting at $895
Used Chevrolet Corvette
298 Great Deals out of 20,672 listings starting at $2,990
Used Ford Mustang SVT Cobra
7 Great Deals out of 288 listings starting at $6,900
Used Ford F-150
2,317 Great Deals out of 184,578 listings starting at $699
Used Chevrolet Silverado 1500
2,112 Great Deals out of 167,056 listings starting at $1,900
Used Chevrolet Monte Carlo
11 Great Deals out of 1,302 listings starting at $2,500
Used Pontiac Grand Prix
29 Great Deals out of 2,739 listings starting at $1,491
Used Chevrolet Impala
514 Great Deals out of 34,211 listings starting at $950
Used BMW 3 Series
1,166 Great Deals out of 33,304 listings starting at $1,000

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.