cooling fans not running on a 2001 pontiac montana

Asked by Jan 26, 2017 at 09:42 PM about the 2001 Pontiac Montana Base Extended

Question type: Maintenance & Repair

The car was giving a 0128 code. Replaced the thermostat because it was stuck open. Also replaced the temperature sending unit in the thermostat housing. The gauge reads the temperature but when it goes over 220 the fans will not come and run. If I disconnect the sensor wire the fans will run but the gauge does not show temperature. Replaced the fan relay. When I turn the A/C on high the fans do not run either they used to. Is the coolant level sensor causing the problem. Need help

2 Answers


Sounds like the coolant temperature sensor. Replace it with an AC Delco sensor. For some reason many aftermarket sensors don't work well or at all in these GMs. HTH. -Jim

Where is the connector plug located

Your Answer

Pontiac Montana Experts

  • #1
  • #2
    Robert Reed
  • #3
    Jim Space
View All

Related Models For Sale

Used Chevrolet Venture
297 listings
Used Honda Odyssey
266 Great Deals out of 33,480 listings starting at $1,295
Used Chrysler Town & Country
120 Great Deals out of 12,583 listings starting at $1,997
Used Dodge Grand Caravan
205 Great Deals out of 30,769 listings starting at $1,499
Used Toyota Sienna
265 Great Deals out of 20,368 listings starting at $1,695
Used Ford Mustang
274 Great Deals out of 38,355 listings starting at $1,995
Used Dodge Caravan
421 listings

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.