car run while it on but when shut off you had to wait awhile until it start again

Asked by Mar 23, 2016 at 12:16 AM about the 2002 Pontiac Aztek STD

Question type: Maintenance & Repair

car run great when it on but when you shut it off and come back to start it up
again you had to wait for awhile at least an hour are so before it start again

2 Answers

1,880

Just guess, but may b temp sending unit?

83,795

It could be the Ignition Control Module starting to go, you can take it out and have tested at Auto Zone. This is an electrical part that heat from the engine would affect when going bad.

Your Answer:

Pontiac Aztek Experts

  • #1
    Tom Demyan
    Reputation
    330
  • #2
    ejhern
    Reputation
    250
  • #3
    Thomas Killen
    Reputation
    200
View All

Related Models For Sale

Used Pontiac Vibe
24 Great Deals out of 804 listings starting at $1,800
Used Chevrolet Malibu
489 Great Deals out of 51,744 listings starting at $1,995
Used Pontiac Grand Prix
9 Great Deals out of 1,755 listings starting at $800
Used Honda Element
21 Great Deals out of 968 listings starting at $2,500
Used Toyota RAV4
526 Great Deals out of 79,409 listings starting at $1,995
Used Toyota Prius
152 Great Deals out of 17,884 listings starting at $1,000
Used Chevrolet Corvette
86 Great Deals out of 15,056 listings starting at $3,620
Used Toyota Corolla
623 Great Deals out of 66,697 listings starting at $900
Used Ford Mustang
260 Great Deals out of 37,872 listings starting at $1,350
Used Pontiac Firebird
3 Great Deals out of 675 listings starting at $4,700
Used Saturn VUE
13 Great Deals out of 1,548 listings starting at $1,488
Used Ford F-150
2,356 Great Deals out of 208,288 listings starting at $998

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.