car run while it on but when shut off you had to wait awhile until it start again

Asked by Mar 23, 2016 at 12:16 AM about the 2002 Pontiac Aztek STD

Question type: Maintenance & Repair

car run great when it on but when you shut it off and come back to start it up
again you had to wait for awhile at least an hour are so before it start again

2 Answers

1,790

Just guess, but may b temp sending unit?

79,105

It could be the Ignition Control Module starting to go, you can take it out and have tested at Auto Zone. This is an electrical part that heat from the engine would affect when going bad.

Your Answer

Pontiac Aztek Experts

  • #1
    Tom Demyan
    Reputation
    320
  • #2
    ejhern
    Reputation
    230
  • #3
    Thomas Killen
    Reputation
    190
View All

Related Models For Sale

Used Pontiac Vibe
13 Great Deals out of 963 listings starting at $1,950
Used Pontiac Firebird
7 Great Deals out of 693 listings starting at $2,850
Used Pontiac Bonneville
4 Great Deals out of 409 listings starting at $1,995
Used Ford Mustang
343 Great Deals out of 42,031 listings starting at $1,488
Used Pontiac Grand Am
952 listings
Used Buick Rendezvous
4 Great Deals out of 885 listings starting at $1,500
Used Pontiac Grand Prix
12 Great Deals out of 2,455 listings starting at $1,900
Used Ford Explorer
1,082 Great Deals out of 67,956 listings starting at $1,500
Used Pontiac Montana
232 listings starting at $1,595

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.