Starts and idles fine. Won't accelerate. I can play with throttle to get it moving. Acts like a fuel delivery issue but have 47 psi even when I hit the gas.

Asked by Jul 05, 2016 at 07:09 PM about the 2003 Pontiac Bonneville SLE

Question type: Maintenance & Repair

When I remove vacuum hose from regulator I get 60 psi fuel pressure.  I have P0102, P0131, P0171. I had a bad MAF but replaced it and I ran perfect for 400 miles last week.  I will replace fuel filter today just because it's time anyway but if it was bad I would expect PSI to be low. If it is parked and open throttle it balks like no fuel but PSI doesn't go below 47.

1 Answer

I put the old MAF back in because it would run perfect for 10 miles before acting up. It ran fine the same as before so I knew the second MAF also failed. Bought a new one AGAIN and replaced it the second time. It has been running fine for 2 weeks now. All fixed.

Your Answer

Pontiac Bonneville Experts

  • #1
    ticklemedaly
    Reputation
    400
  • #2
    dandyoun
    Reputation
    380
  • #3
    Js08016
    Reputation
    370
View All

Related Models For Sale

Used Pontiac Grand Prix
11 Great Deals out of 2,293 listings starting at $1,900
Used Chevrolet Impala
466 Great Deals out of 31,445 listings starting at $1,000
Used Buick Regal
134 Great Deals out of 5,008 listings starting at $2,495
Used Chevrolet Monte Carlo
6 Great Deals out of 1,106 listings starting at $1,125
Used Pontiac GTO
392 listings starting at $3,950
Used Pontiac Firebird
5 Great Deals out of 690 listings starting at $3,911
Used Chevrolet Malibu
943 Great Deals out of 52,790 listings starting at $1,599
Used Chevrolet Camaro
358 Great Deals out of 31,467 listings starting at $3,495
Used Nissan Maxima
316 Great Deals out of 20,162 listings starting at $1,495

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.