Turn signals stop working and start working again in my 04 oldsmobile alero 3.4 v6

Asked by Apr 14, 2014 at 10:13 PM about the 2004 Oldsmobile Alero GL

Question type: Maintenance & Repair

1 Answer

20

i had the same issue. it was a faulty hazard switch. i had it replaced the turn signals work fine

2 of 2 people found this helpful.

Your Answer

Add photo

Related Questions

Search Oldsmobile Alero Questions

Oldsmobile Alero Experts

#1 sun4shine2006
sun4shine2006
Reputation 550
#2 Chris Kelso
Chris Kelso
Reputation 210
#3 Nir Eliyaho
Nir Eliyaho
Reputation 200
View All

Related Models For Sale

Used Honda Accord
1,039 Great Deals out of 77,388 listings starting at $999
Used Nissan Altima
1,250 Great Deals out of 79,776 listings starting at $1,500
Used Chevrolet Malibu
1,066 Great Deals out of 78,505 listings starting at $1,500
Used Pontiac Grand Prix
38 Great Deals out of 2,918 listings starting at $1,995
Used Ford Focus
692 Great Deals out of 57,469 listings starting at $795
Used Pontiac Grand Am
1,169 listings starting at $1,000
Used Nissan Maxima
317 Great Deals out of 25,019 listings starting at $999
Used Chevrolet Impala
625 Great Deals out of 35,400 listings starting at $899
Used Toyota Camry
1,109 Great Deals out of 91,351 listings starting at $1,222
Used Honda Civic
859 Great Deals out of 89,077 listings starting at $1,299
Used Ford Ranger
178 Great Deals out of 5,692 listings starting at $950

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.