wont keep running

Asked by Sep 14, 2011 at 09:44 AM about the 1996 Ford Bronco XL 4WD

Question type: Maintenance & Repair

replaced fuel filter and ignition module either wont start or does start will run 15 min and die--any suggestions

3 Answers

sounds like the fuel pump is getting week.

check the distribuitor it have two sensors in it ,i had the same issue and replaced it and never a problem after that

30

im having the same problem with my 89o 351w EFI. I replaced the filter and i can hear the the pump priming and if i leave it for about ten minutes and it will start up and run for about ten seconds and die again like its running out of gas. need some help thanks

3 of 3 people found this helpful.

Your Answer

Add photo

Related Questions

Bronco

Looking for a Used Bronco in your area?

CarGurus has 203 nationwide Bronco listings and the tools to find you a great deal.

ZIP:

Search Ford Bronco Questions

Ford Bronco Experts

#1 tennisshoes
tennisshoes
Reputation 420
#2 Clayton Cameron
Clayton Cameron
Reputation 170
#3 Js08016
Js08016
Reputation 160
View All

Related Models For Sale

Used Ford F-150
2,055 Great Deals out of 207,336 listings starting at $1,499
Used Jeep Wrangler
260 Great Deals out of 16,543 listings starting at $2,590
Used Ford Mustang
541 Great Deals out of 45,846 listings starting at $1,999
Used Chevrolet Blazer
3 Great Deals out of 1,188 listings starting at $1,820
Used Ford Explorer
928 Great Deals out of 70,251 listings starting at $997
Used Toyota Land Cruiser
11 Great Deals out of 1,034 listings starting at $3,700
Used Chevrolet Tahoe
559 Great Deals out of 31,371 listings starting at $1,500
Used Ford F-250
469 listings starting at $2,000
Used Chevrolet Camaro
243 Great Deals out of 31,194 listings starting at $369

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.