Not getting enough voltage

40

Asked by Feb 28, 2016 at 01:28 AM about the 1990 Mitsubishi Eclipse GS 2.0

Question type: Maintenance & Repair

New alt and battery I jump the car and after 5 mins
of running with the heat and lights on everything
starts getting dim.

1 Answer

78,985

Sounds like the alternator is not working, either take it off to be tested, or get the car somewhere to be tested. If you have a volt meter there should be 14.5 DCV when running at the battery posts.

1 of 1 people found this helpful.

Your Answer

Mitsubishi Eclipse Experts

  • #1
    dandyoun
    Reputation
    1,660
  • #2
    Daniel Foster
    Reputation
    740
  • #3
    Tom Demyan
    Reputation
    490
View All

Related Models For Sale

Used Ford Mustang
354 Great Deals out of 42,606 listings starting at $1,488
Used Honda Civic
616 Great Deals out of 54,503 listings starting at $1,500
Used Chevrolet Camaro
415 Great Deals out of 31,702 listings starting at $3,495
Used BMW 3 Series
1,143 Great Deals out of 34,322 listings starting at $1,209
Used Toyota Celica
4 Great Deals out of 296 listings starting at $1,984

Used Cars For Sale

2012 Mitsubishi Eclipse For Sale
39 listings starting at $5,762
2011 Mitsubishi Eclipse For Sale
5 Great Deals out of 55 listings starting at $5,400
2009 Mitsubishi Eclipse For Sale
117 listings starting at $3,900
2008 Mitsubishi Eclipse For Sale
142 listings starting at $2,900

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.