Not getting enough voltage

40

Asked by Feb 28, 2016 at 01:28 AM about the 1990 Mitsubishi Eclipse GS 2.0

Question type: Maintenance & Repair

New alt and battery I jump the car and after 5 mins
of running with the heat and lights on everything
starts getting dim.

1 Answer

74,755

Sounds like the alternator is not working, either take it off to be tested, or get the car somewhere to be tested. If you have a volt meter there should be 14.5 DCV when running at the battery posts.

1 of 1 people found this helpful.

Your Answer

Mitsubishi Eclipse Experts

  • #1
    dandyoun
    Reputation
    1,660
  • #2
    Daniel Foster
    Reputation
    740
  • #3
    Tom Demyan
    Reputation
    470
View All

Related Models For Sale

Used Ford Mustang
592 Great Deals out of 36,382 listings starting at $899
Used Honda Civic
784 Great Deals out of 70,025 listings starting at $1,500
Used Chevrolet Camaro
444 Great Deals out of 30,829 listings starting at $1,450
Used Mitsubishi 3000GT
90 listings starting at $3,499
Used BMW 3 Series
1,108 Great Deals out of 33,823 listings starting at $1,000
Used Honda Accord
1,011 Great Deals out of 60,152 listings starting at $1,099

Used Cars For Sale

2012 Mitsubishi Eclipse For Sale
53 listings starting at $5,338
2011 Mitsubishi Eclipse For Sale
4 Great Deals out of 50 listings starting at $4,000
2009 Mitsubishi Eclipse For Sale
121 listings starting at $2,950
2008 Mitsubishi Eclipse For Sale
3 Great Deals out of 183 listings starting at $2,995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.