Starts and dies shortly with sputter

10

Asked by Jun 24, 2017 at 12:26 PM about the 1997 Mercury Villager 3 Dr LS Passenger Van

Question type: Maintenance & Repair

I have had it to do this 3 times now! I have replaced
the battery, fuel filter, and the very expressive maf
sensor and still no luck.
Runs for about a half minute and stalls down and
sputters.
I can restart and does the same thing!
Have had it in the shop second time this happened
and after a day and a half they charged me and
couldn't find a problem.
I am very frustrated this is my only transportation
and I am failing to be able to get back and forth to
work!

1 Answer

10

not sure how to add a comment/follow-up. but, I just spent $172 for a MAF sensor and tht didn't do a thing for me!!

1 of 1 people found this helpful.

Your Answer

Mercury Villager Experts

  • #1
    Tom Demyan
    Reputation
    280
  • #2
    tenspeed
    Reputation
    170
  • #3
    dandyoun
    Reputation
    150
View All

Related Models For Sale

Used Nissan Quest
81 Great Deals out of 2,958 listings starting at $2,300
Used Toyota Sienna
472 Great Deals out of 23,432 listings starting at $1,500
Used Dodge Caravan
571 listings starting at $1,949
Used Chrysler Town & Country
331 Great Deals out of 13,487 listings starting at $1,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.