Starts and dies shortly with sputter


Asked by Jun 24, 2017 at 12:26 PM about the 1997 Mercury Villager 3 Dr LS Passenger Van

Question type: Maintenance & Repair

I have had it to do this 3 times now! I have replaced
the battery, fuel filter, and the very expressive maf
sensor and still no luck.
Runs for about a half minute and stalls down and
I can restart and does the same thing!
Have had it in the shop second time this happened
and after a day and a half they charged me and
couldn't find a problem.
I am very frustrated this is my only transportation
and I am failing to be able to get back and forth to

1 Answer


not sure how to add a comment/follow-up. but, I just spent $172 for a MAF sensor and tht didn't do a thing for me!!

1 of 1 people found this helpful.

Your Answer

Mercury Villager Experts

  • #1
    Tom Demyan
  • #2
  • #3
View All

Related Models For Sale

Used Nissan Quest
31 Great Deals out of 2,139 listings starting at $1,800
Used Toyota Sienna
265 Great Deals out of 19,044 listings starting at $1,300
Used GMC Yukon
367 Great Deals out of 18,483 listings starting at $1,800
Used Dodge Grand Caravan
214 Great Deals out of 30,674 listings starting at $1,950
Used Honda Odyssey
288 Great Deals out of 32,742 listings starting at $2,200
Used Mercury Mountaineer
14 Great Deals out of 761 listings starting at $1,500
Used Mercury Sable
609 listings starting at $1,995
Used Chevrolet Venture
286 listings

Used Cars For Sale

2002 Mercury Villager For Sale
17 listings starting at $2,900

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.