Mercury villager

Asked by Aug 07, 2016 at 12:05 PM about the 1997 Mercury Villager 3 Dr LS Passenger Van

Question type: Maintenance & Repair

97 mercury villager. I have replace the starter plus
change the spark plugs. After all this it hust started
making a shaking noise when the car in on drive

2 Answers

13,475

Spark plug wires are not in the correct firing order sequence double Check them twice! This vehicle is really a NISSAN Quest, Ford marketed it as a Mercury.

1 of 1 people found this helpful.
1,485

You could have a bad spark plug wire(s), bad distributor cap, or a bad fuel injector.(all these things happened to mine). Is the check engine light on? Have you read the diagnostic codes with a scanner? Some auto shops will do it for you. (All this is if you have the plug wires sequence correct).

2 of 2 people found this helpful.

Your Answer

Mercury Villager Experts

  • #1
    Tom Demyan
    Reputation
    280
  • #2
    tenspeed
    Reputation
    170
  • #3
    dandyoun
    Reputation
    150
View All

Related Models For Sale

Used Nissan Quest
85 Great Deals out of 2,945 listings starting at $2,500
Used Dodge Caravan
584 listings starting at $1,949
Used Toyota Sienna
480 Great Deals out of 23,458 listings starting at $1,500
Used Chrysler Town & Country
346 Great Deals out of 13,477 listings starting at $1,999

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.