I have a 1999 Mercury Villager that keeps shutting off the battery light stays on along with the brake light but it is a brand new battery. I also have a hole in the tail pipe and it aputters and the the car shuts off. I have changed the fuel filter and the starter

55

Asked by Mar 15, 2014 at 11:18 AM about the 1999 Mercury Villager 4 Dr Estate Passenger Van

Question type: Maintenance & Repair

I have a 1999 Mercury Villager that keeps shutting off the battery light stays on along with the brake light but it is a brand new battery. I also have a hole in the tail pipe and it aputters and the the car shuts off. I have changed the fuel filter and the starter. The gas get in the car what is causing my battery light and brake light to come on then the car shuts off after running for 10 minutes

2 Answers

55

I found out the answer I think the alternator belt is missing.

1 of 1 people found this helpful.

Really f****** alternator come on

Your Answer

Add photo

Related Questions

Search Mercury Villager Questions

Mercury Villager Experts

#1 Tom Demyan
Tom Demyan
Reputation 260
#2 tenspeed
tenspeed
Reputation 160
#3 dandyoun
dandyoun
Reputation 150
View All

Related Models For Sale

Used Nissan Quest
62 Great Deals out of 2,643 listings starting at $2,995
Used Honda Odyssey
247 Great Deals out of 19,855 listings starting at $1,495
Used Dodge Grand Caravan
158 Great Deals out of 25,122 listings starting at $2,000
Used Ford Explorer
912 Great Deals out of 64,628 listings starting at $799
Used Toyota Sienna
242 Great Deals out of 28,730 listings starting at $2,180
Used Mercedes-Benz Sprinter
1,860 listings starting at $15,500
Used Ford Focus
820 Great Deals out of 54,869 listings starting at $1,200

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.