High beams working but not low beams

Asked by Jun 11, 2017 at 09:37 PM about the 2000 Mercury Sable GS

Question type: Maintenance & Repair

Low beams were coming on after a minute or two but now not working at all.
High beams are working ok.

No answers yet

Your Answer

Add photo

Related Questions

Search Mercury Sable Questions

Mercury Sable Experts

#1 JP1956
JP1956
Reputation 680
#2 Tom Demyan
Tom Demyan
Reputation 610
#3 Guy Outland
Guy Outland
Reputation 400
View All

Related Models For Sale

Used Ford Taurus
261 Great Deals out of 17,944 listings starting at $1,499
Used Mercury Grand Marquis
32 Great Deals out of 1,759 listings starting at $1,700
Used Honda Accord
995 Great Deals out of 62,548 listings starting at $999
Used Ford Focus
747 Great Deals out of 53,009 listings starting at $1,299
Used Chevrolet Impala
566 Great Deals out of 34,649 listings starting at $1,000
Used Ford Escape
1,098 Great Deals out of 84,569 listings starting at $1,495
Used Toyota Camry
1,063 Great Deals out of 72,893 listings starting at $1,000
Used Chevrolet Malibu
1,222 Great Deals out of 77,946 listings starting at $1,500
Used Honda Civic
818 Great Deals out of 78,123 listings starting at $900
Used Hyundai Sonata
749 Great Deals out of 47,196 listings starting at $199
Used Pontiac Grand Am
1,088 listings starting at $1,599

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.