replaced the water pump, thermostat and radiator care still run hot while setting idle

Asked by Aug 13, 2017 at 12:48 PM about the 2002 Mercury Sable LS Premium Sedan FWD

Question type: Maintenance & Repair

2 Answers

77,535

Have you checked the radiator fan,s and made sure they are working?

4,040

Yep fans also are you sure system is completely full and no air exists? Testing these fans are easy, 2 wires from fan to battery.

Your Answer:

Mercury Sable Experts

  • #1
    JP1956
    Reputation
    840
  • #2
    Tom Demyan
    Reputation
    730
  • #3
    Guy Outland
    Reputation
    410
View All

Related Models For Sale

Used Ford Taurus
268 Great Deals out of 16,160 listings starting at $986
Used Mercury Grand Marquis
17 Great Deals out of 1,286 listings starting at $1,250
Used Ford F-150
2,251 Great Deals out of 188,015 listings starting at $1,200
Used Toyota Camry
981 Great Deals out of 70,545 listings starting at $1,137
Used Chevrolet Impala
549 Great Deals out of 25,538 listings starting at $790
Used Ford Crown Victoria
751 listings starting at $1,900
Used Honda Accord
722 Great Deals out of 97,684 listings starting at $750
Used Ford Escape
1,239 Great Deals out of 96,730 listings starting at $975
Used Dodge Grand Caravan
261 Great Deals out of 27,631 listings starting at $1,488

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.