replaced the water pump, thermostat and radiator care still run hot while setting idle

Asked by Aug 13, 2017 at 12:48 PM about the 2002 Mercury Sable LS

Question type: Maintenance & Repair

2 Answers

67,495

Have you checked the radiator fan,s and made sure they are working?

810

Yep fans also are you sure system is completely full and no air exists? Testing these fans are easy, 2 wires from fan to battery.

Your Answer

Mercury Sable Experts

  • #1
    JP1956
    Reputation
    680
  • #2
    Tom Demyan
    Reputation
    620
  • #3
    Guy Outland
    Reputation
    400
View All

Related Models For Sale

Used Ford Taurus
246 Great Deals out of 17,885 listings starting at $1,499
Used Mercury Grand Marquis
31 Great Deals out of 1,729 listings starting at $1,700
Used Ford Focus
781 Great Deals out of 54,310 listings starting at $1,495
Used Honda Accord
1,030 Great Deals out of 63,282 listings starting at $999
Used Chevrolet Impala
611 Great Deals out of 34,797 listings starting at $1,250
Used Ford Escape
1,140 Great Deals out of 85,648 listings starting at $999
Used Toyota Camry
1,108 Great Deals out of 72,800 listings starting at $1,000
Used Chevrolet Malibu
1,240 Great Deals out of 78,130 listings starting at $1,500
Used Hyundai Sonata
757 Great Deals out of 47,840 listings starting at $199
Used Honda Civic
848 Great Deals out of 78,667 listings starting at $900

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.