Running Hot

Asked by Oct 16, 2016 at 10:17 PM about the 2002 Mercury Sable LS

Question type: Maintenance & Repair

Can someone please give me details I've put new
thermostat in , new water heater Hose,  and new
pressure feedback sensor , and it still runs hot
after a min idling I've also flushed radiator a few
times also

1 Answer

3,505

It could be air locked, or your water pump is most likely shot and not circulating at all. It may also be, but not probable, a blown head gasket.

Your Answer

Mercury Sable Experts

  • #1
    JP1956
    Reputation
    690
  • #2
    Tom Demyan
    Reputation
    620
  • #3
    Guy Outland
    Reputation
    400
View All

Related Models For Sale

Used Ford Taurus
255 Great Deals out of 16,486 listings starting at $1,850
Used Mercury Grand Marquis
30 Great Deals out of 1,744 listings starting at $1,950
Used Toyota Camry
1,057 Great Deals out of 70,426 listings starting at $295
Used Ford Escape
1,043 Great Deals out of 86,080 listings starting at $1,188
Used Honda Accord
1,068 Great Deals out of 60,935 listings starting at $999
Used Chevrolet Malibu
1,090 Great Deals out of 71,646 listings starting at $1,896
Used Ford Mustang
692 Great Deals out of 38,314 listings starting at $895
Used Nissan Altima
1,032 Great Deals out of 74,835 listings starting at $1,200
Used Chevrolet Impala
510 Great Deals out of 33,708 listings starting at $950

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.