Running Hot

Asked by Oct 16, 2016 at 10:17 PM about the 2002 Mercury Sable LS

Question type: Maintenance & Repair

Can someone please give me details I've put new
thermostat in , new water heater Hose,  and new
pressure feedback sensor , and it still runs hot
after a min idling I've also flushed radiator a few
times also

1 Answer

3,445

It could be air locked, or your water pump is most likely shot and not circulating at all. It may also be, but not probable, a blown head gasket.

Your Answer

Add photo

Related Questions

Search Mercury Sable Questions

Mercury Sable Experts

#1 JP1956
JP1956
Reputation 680
#2 Tom Demyan
Tom Demyan
Reputation 600
#3 Guy Outland
Guy Outland
Reputation 400
View All

Related Models For Sale

Used Ford Taurus
272 Great Deals out of 18,688 listings starting at $1,499
Used Mercury Grand Marquis
29 Great Deals out of 1,794 listings starting at $2,250
Used Toyota Camry
1,207 Great Deals out of 82,541 listings starting at $750
Used Ford Explorer
914 Great Deals out of 63,252 listings starting at $700
Used Ford Focus
832 Great Deals out of 53,825 listings starting at $1,495
Used Honda Accord
1,057 Great Deals out of 66,823 listings starting at $1,000
Used Ford Escape
1,249 Great Deals out of 84,640 listings starting at $995
Used Chevrolet Impala
553 Great Deals out of 35,458 listings starting at $899
Used Chevrolet Malibu
1,119 Great Deals out of 80,273 listings starting at $2,500
Used Nissan Altima
1,301 Great Deals out of 74,561 listings starting at $1,000
Used Jeep Grand Cherokee
1,033 Great Deals out of 72,325 listings starting at $1,200

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.