2000 Mazda Protege no electrical power

Asked by Jun 25, 2017 at 12:33 PM about the 2000 Mazda Protege ES

Question type: Maintenance & Repair

My 2000 Mazda Protege has no power at all. When  
I disconnect the ground on the battery and
reconnect, everything on the dash comes back on,
but when I go to start it, it clicks, and everything
shuts completely off again. It looks like there is
already a new alternator on it, and I don't know how
old the battery is. I've had it for 2 weeks. Last time
it did it I just disconnected the battery and charged
it out of car and it worked for 2 weeks. Now it's
died again and it won't hold a charge or something.
I think its the alternator diode causing too much
parasitic draw, but its too weird to be that simple.
Just need some other opinions.

No answers yet

Your Answer

Mazda Protege Experts

  • #1
    James Kithuka
    Reputation
    290
  • #2
    dandyoun
    Reputation
    220
  • #3
    Js08016
    Reputation
    160
View All

Related Models For Sale

Used Honda Civic
810 Great Deals out of 72,283 listings starting at $1,000
Used Toyota Corolla
887 Great Deals out of 56,798 listings starting at $1,099
Used Honda Accord
1,041 Great Deals out of 60,748 listings starting at $999
Used Mazda Tribute
17 Great Deals out of 891 listings starting at $850
Used Mazda MX-5 Miata
72 Great Deals out of 4,308 listings starting at $1,900
Used Ford F-150
2,280 Great Deals out of 181,624 listings starting at $1,000
Used BMW 3 Series
1,122 Great Deals out of 32,826 listings starting at $1,000
Used Toyota RAV4
805 Great Deals out of 50,365 listings starting at $1,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.