My 2000 mazda 626 runs good for approx 20 minutes then starts sputtering and the overdrive light starts flashing. Seems to happen mostly when driving between 35-45 mph. Don't think the transmission is bad or would happen before driving awile. Any clues what is wrong?

Asked by Mar 05, 2007 at 10:31 AM about the 2000 Mazda 626 LX

Question type: Maintenance & Repair

1 Answer

16,020

Dear GeraldD-- It sounds to me that the overdrive is kicking in and out on your 2000 Mazda 626, causing the sputtering feeling. It could be low transmission fluid, a bad relay, or in a rare case, an overheated transmission. Have a transmission specialist look at it. Good luck from Bovan.

1 people found this helpful.
Best Answer Mark helpful

Your Answer:

Mazda 626 Experts

  • #1
    littlehorn
    Reputation
    420
  • #2
    tropikalpirate
    Reputation
    290
  • #3
    tennisshoes
    Reputation
    210
View All

Related Models For Sale

Used Honda Civic
376 Great Deals out of 49,269 listings starting at $1,499
Used Toyota Camry
758 Great Deals out of 73,417 listings starting at $1,195
Used Honda Accord
566 Great Deals out of 103,985 listings starting at $950
Used Mazda MX-5 Miata
52 Great Deals out of 4,637 listings starting at $1,900
Used Mazda Protege
172 listings starting at $2,195

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.