No power on acceleration

135

Asked by Jun 27, 2011 at 01:32 PM about the 2001 Mazda Tribute ES V6 4WD

Question type: Maintenance & Repair

I changed the valve cover gasket and the oil filter and now when I try to drive the car it doesn't have any power.  It starts and idles good (even in nuetral), but once I put it in drive and try to go the dash lights start to blink, brakes do not work and the more gas I give it the worse it gets.  I've checked all hoses MAF sensor, catalytic converter and replaced the fuel filter.  Any suggestions, someone has said that it may be the computer because I did not disconnect the battery first.

1 Answer

135

Found the problem, it was the rear catalytic converter.

9 of 9 people found this helpful.

Your Answer

Mazda Tribute Experts

  • #1
    Tom Demyan
    Reputation
    1,040
  • #2
    Js08016
    Reputation
    260
  • #3
    Reelin68
    Reputation
    230
View All

Related Models For Sale

Used Ford Escape
1,059 Great Deals out of 87,254 listings starting at $1,088
Used Honda CR-V
812 Great Deals out of 54,677 listings starting at $1,750
Used Toyota RAV4
822 Great Deals out of 51,119 listings starting at $1,500
Used Subaru Forester
408 Great Deals out of 34,020 listings starting at $1,295
Used Toyota 4Runner
299 Great Deals out of 21,851 listings starting at $1,700
Used Ford Explorer
858 Great Deals out of 63,389 listings starting at $995

Used Cars For Sale

2011 Mazda Tribute For Sale
28 listings starting at $5,950
2010 Mazda Tribute For Sale
27 listings starting at $3,991
2009 Mazda Tribute For Sale
32 listings starting at $5,950
2008 Mazda Tribute For Sale
4 Great Deals out of 120 listings starting at $3,800
2006 Mazda Tribute For Sale
4 Great Deals out of 122 listings starting at $1,990

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.