No power on acceleration

135

Asked by Jun 27, 2011 at 01:32 PM about the 2001 Mazda Tribute ES V6 4WD

Question type: Maintenance & Repair

I changed the valve cover gasket and the oil filter and now when I try to drive the car it doesn't have any power.  It starts and idles good (even in nuetral), but once I put it in drive and try to go the dash lights start to blink, brakes do not work and the more gas I give it the worse it gets.  I've checked all hoses MAF sensor, catalytic converter and replaced the fuel filter.  Any suggestions, someone has said that it may be the computer because I did not disconnect the battery first.

1 Answer

135

Found the problem, it was the rear catalytic converter.

9 out of 9 people think this is helpful.

Your Answer

Add photo

Related Questions

Search Mazda Tribute Questions

Mazda Tribute Experts

#1 Tom Demyan
Tom Demyan
Reputation 880
#2 FordNut
FordNut
Reputation 280
#3 Reelin68
Reelin68
Reputation 190
View All

Related Models For Sale

Used Ford Escape
1,644 Great Deals out of 84,908 listings starting at $995
Used Honda CR-V
1,247 Great Deals out of 74,493 listings starting at $1,999
Used Toyota RAV4
1,116 Great Deals out of 53,918 listings starting at $1,350
Used Toyota 4Runner
375 Great Deals out of 20,042 listings starting at $2,499
Used Nissan Xterra
121 Great Deals out of 3,692 listings starting at $1,400
Used Toyota Highlander
653 Great Deals out of 27,634 listings starting at $2,988
Used Ford Explorer
1,377 Great Deals out of 71,976 listings starting at $985
Used Subaru Forester
354 Great Deals out of 20,158 listings starting at $1,200

Used Cars For Sale

2011 Mazda Tribute For Sale
28 listings starting at $6,995
2010 Mazda Tribute For Sale
6 Great Deals out of 46 listings starting at $2,800
2009 Mazda Tribute For Sale
30 listings starting at $5,492
2008 Mazda Tribute For Sale
143 listings starting at $3,495
2006 Mazda Tribute For Sale
157 listings starting at $3,999