My 1998 ford escort wagon starts but if i apply gas it seems like it isnt getting any and dies immediately

Asked by Jul 05, 2015 at 10:04 PM about the 1998 Ford Escort 4 Dr SE Wagon

Question type: Maintenance & Repair

I have had a brake light short and it blew a brake fuse replaced it with a new one and
brake lights worked again. As i started the engine, I applyed some gas and the engine
died immediatly. can this be a clogged fuel filter?

1 Answer

19,980

Yes it can be a clogged fuel filter but also check the air filter and clean throttle body also add some fuel injector cleaner to gas tank.

Your Answer

Ford Escort Experts

  • #1
    Tom Demyan
    Reputation
    1,040
  • #2
    dandyoun
    Reputation
    880
  • #3
    tennisshoes
    Reputation
    430
View All

Related Models For Sale

Used Ford Focus
803 Great Deals out of 55,008 listings starting at $800
Used Ford Mustang
590 Great Deals out of 36,206 listings starting at $1,200
Used Ford Explorer
908 Great Deals out of 67,921 listings starting at $1,495
Used Honda Civic
753 Great Deals out of 69,402 listings starting at $1,000
Used Ford Taurus
191 Great Deals out of 15,799 listings starting at $1,850
Used Ford F-150
2,565 Great Deals out of 195,338 listings starting at $1,300
Used Honda Accord
1,024 Great Deals out of 57,886 listings starting at $1,099
Used Ford Fiesta
167 Great Deals out of 16,742 listings starting at $2,860
Used Toyota Corolla
782 Great Deals out of 53,913 listings starting at $1,200
Used Toyota Camry
931 Great Deals out of 80,594 listings starting at $1,440
Used BMW 3 Series
1,089 Great Deals out of 33,276 listings starting at $999

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.