Isuzu 2000 Rodeo 3.2 V-6 won't accelerate in Drive past 5 mph. No check engine lights or warnings either.

Asked by Jan 06, 2012 at 08:24 PM about the 2000 Isuzu Rodeo LS 4WD

Question type: Maintenance & Repair

I have a 2000 Isuzu Rodeo 3.2 V-6.  Just recently it started to not accelerate when
in D.  It idles fine and doesn't feel rough at all.  Also, there are no engine lights or
warnings at all.  However, when in D it feels limp and won't accelerate.  Also, at
times when I put it in R it will stall as soon as I release the brake, but doesn't
happen all the time, and if I pull forward, then it'll reverse just fine.  It seems to
stall when it's sat for a while in Park and you try to go in R first thing out of Park.  
Any ideas?  I've been reading around and some say it might be the TPS (Throttle
Position Sensor).  It's about $70 at O'Reilly, but I don't want to spend that if it won't
fix my problem.

1 Answer

no on TPS,is a tranny issue.

2 of 2 people found this helpful.

Your Answer

Isuzu Rodeo Experts

  • #1
    tas33
    Reputation
    440
  • #2
    dandyoun
    Reputation
    390
  • #3
    tennisshoes
    Reputation
    320
View All

Related Models For Sale

Used Toyota 4Runner
319 Great Deals out of 27,207 listings starting at $1,900
Used Honda Passport
54 listings starting at $3,995
Used Nissan Pathfinder
489 Great Deals out of 23,881 listings starting at $895
Used Jeep Cherokee
470 Great Deals out of 58,285 listings starting at $3,500
Used Isuzu Amigo
9 listings
Used Honda Accord
925 Great Deals out of 78,233 listings starting at $1,295
Used Isuzu Trooper
68 listings starting at $3,595
Used Mercedes-Benz C-Class
843 Great Deals out of 26,004 listings starting at $1,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.