Why would one injector spray and the other not on my 1989 k1500 5.7

Asked by Jan 04, 2017 at 07:58 PM about the 1989 Chevrolet C/K 1500 Silverado 4WD

Question type: General

2 Answers

79,145

Just a bad injector, probably plugged, just double check that there is voltage at the plugin on top of the injector. Otherwise just replace both injectors.

109,905

Could be a bad a injector, or the injector driver for that injector, you need to test for both power an trigger signals at the injectors, if you loose either of these the injector will not flow, If you have power but no trigger then trace the trigger wire for a short, if none are found the check the signal right at the ECM if no signal exists then it it the ECM.

Your Answer

Chevrolet C/K 1500 Experts

  • #1
    Andrew Olsen
    Reputation
    4,000
  • #2
    John Saffrahn
    Reputation
    2,690
  • #3
    Rowefast
    Reputation
    2,290
View All

Related Models For Sale

Used GMC Sierra 1500
1,101 Great Deals out of 61,753 listings starting at $1,295
Used Ford F-150
2,997 Great Deals out of 230,656 listings starting at $1,300
Used Chevrolet C/K 2500
217 listings starting at $2,495
Used Chevrolet C/K 3500
178 listings starting at $4,000
Used Chevrolet S-10
8 Great Deals out of 1,155 listings starting at $950
Used Chevrolet Camaro
373 Great Deals out of 31,435 listings starting at $3,495

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.