i have a 1990 Chevy silverado 1500 and when i put a new ect sensor in it it will not start but when i put the old one back in it will satrt?

Asked by Feb 14, 2017 at 12:00 PM about the 1990 Chevrolet C/K 1500 Extended Cab LB

Question type: Maintenance & Repair

1 Answer

74,765

Either the new one is faulty or there is a broken wire at the plugin for the ECT. You would have to check for continuity in the wire from the plugin to see if it is intermittent.

Your Answer

Chevrolet C/K 1500 Experts

  • #1
    Andrew Olsen
    Reputation
    3,730
  • #2
    John Saffrahn
    Reputation
    2,600
  • #3
    Rowefast
    Reputation
    2,200
View All

Related Models For Sale

Used GMC Sierra 1500
969 Great Deals out of 65,610 listings starting at $1,975
Used Ford F-150
2,493 Great Deals out of 195,941 listings starting at $1,500
Used Chevrolet C/K 2500
205 listings starting at $3,994
Used Chevrolet Camaro
413 Great Deals out of 30,554 listings starting at $1,450
Used Chevrolet C/K 3500
3 Great Deals out of 237 listings starting at $1,500
Used Chevrolet S-10
19 Great Deals out of 1,242 listings starting at $1,600

Used Cars For Sale

1998 Chevrolet C/K 1500 For Sale
172 listings starting at $3,500
1997 Chevrolet C/K 1500 For Sale
127 listings starting at $3,795
1996 Chevrolet C/K 1500 For Sale
98 listings starting at $3,888

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.