Tune up gone wrong?

Asked by Sep 21, 2016 at 01:57 AM about the 1993 Chevrolet C/K 1500 Silverado Standard Cab SB 4WD

Question type: Maintenance & Repair

I had a tune up today on my 93 chevy
silverado.  New spark plugs, oil filter, and
ignition wires.  It was running great before
all these "updates" now my truck shakes in
idle, and it sounds as if it wants to quit
running.  The batter needle on my gage goes
up and down when idle.  And I have even
slower acceleration speed than before.  Ijust
paid good money for these fixes, what is
wrong now?  Meinike screwed up, or what?

2 Answers

104,235

Sounds like it, possible ignition wires on incorrectly, as far as the voltmeter fluxuation, check the large red wire that comes from the battery to the power distribution box, these are known to go bad right at the battery due to internal corrosion.

1 of 1 people found this helpful.
111,785

The first issue you yook the car to Meinike, like shoe said check the ignition wiring

4 of 4 people found this helpful.

Your Answer

Chevrolet C/K 1500 Experts

  • #1
    Andrew Olsen
    Reputation
    3,750
  • #2
    John Saffrahn
    Reputation
    2,650
  • #3
    Rowefast
    Reputation
    2,200
View All

Related Models For Sale

Used GMC Sierra 1500
1,115 Great Deals out of 65,137 listings starting at $1,750
Used Ford F-150
2,780 Great Deals out of 212,570 listings starting at $1,300
Used Chevrolet C/K 2500
208 listings starting at $5,498
Used Dodge Ram 1500
401 Great Deals out of 10,815 listings starting at $1,499
Used Chevrolet Camaro
439 Great Deals out of 31,299 listings starting at $3,550
Used Chevrolet C/K 3500
207 listings starting at $3,995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.