why am i getting no power to the fuel pump after replacing relay and fuel pump on 96 chevy c1500

10

Asked by Jun 06, 2016 at 06:39 AM about the 1996 Chevrolet C/K 1500 WT LB 4WD

Question type: Maintenance & Repair

i have did power test. it seems as though im getting power from the orange
wire where the relay goes and also from the harness under the cab that runs
to the fuel pump. but no power to the exact harness that runs down to the fuel
pump..so with the key fuel pump is not engaging

1 Answer

14,165

Check all fuses / relays in the fuse boxes locations under hood too, connect your multimeter to the fuel pump connector check for voltage KOEO and have someone turn the key to starting position and while you check for voltage again.. harness might have an open under the bed of the truck inspect it.

2 of 2 people found this helpful.

Your Answer

Chevrolet C/K 1500 Experts

  • #1
    Andrew Olsen
    Reputation
    4,020
  • #2
    John Saffrahn
    Reputation
    2,690
  • #3
    Rowefast
    Reputation
    2,290
View All

Related Models For Sale

Used GMC Sierra 1500
1,097 Great Deals out of 61,964 listings starting at $1,295
Used Ford F-150
2,998 Great Deals out of 231,249 listings starting at $1,300
Used Chevrolet C/K 2500
215 listings starting at $3,500
Used Dodge Ram 1500
299 Great Deals out of 10,624 listings starting at $1,950
Used Chevrolet Tahoe
801 Great Deals out of 40,245 listings starting at $1,799
Used Chevrolet C/K 3500
180 listings starting at $4,000
Used Toyota Tacoma
557 Great Deals out of 41,053 listings starting at $2,995
Used Chevrolet Camaro
371 Great Deals out of 31,504 listings starting at $3,000
Used Chevrolet S-10
8 Great Deals out of 1,104 listings starting at $950

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.