why am i getting no power to the fuel pump after replacing relay and fuel pump on 96 chevy c1500

10

Asked by Jun 06, 2016 at 06:39 AM about the 1996 Chevrolet C/K 1500 WT LB 4WD

Question type: Maintenance & Repair

i have did power test. it seems as though im getting power from the orange
wire where the relay goes and also from the harness under the cab that runs
to the fuel pump. but no power to the exact harness that runs down to the fuel
pump..so with the key fuel pump is not engaging

1 Answer

13,485

Check all fuses / relays in the fuse boxes locations under hood too, connect your multimeter to the fuel pump connector check for voltage KOEO and have someone turn the key to starting position and while you check for voltage again.. harness might have an open under the bed of the truck inspect it.

2 of 2 people found this helpful.

Your Answer

Chevrolet C/K 1500 Experts

  • #1
    Andrew Olsen
    Reputation
    3,840
  • #2
    John Saffrahn
    Reputation
    2,650
  • #3
    Rowefast
    Reputation
    2,210
View All

Related Models For Sale

Used GMC Sierra 1500
1,199 Great Deals out of 64,603 listings starting at $999
Used Ford F-150
3,337 Great Deals out of 221,765 listings starting at $1,200
Used Chevrolet C/K 2500
208 listings starting at $2,999
Used Dodge Ram 1500
428 Great Deals out of 11,102 listings starting at $1,495
Used Chevrolet Tahoe
807 Great Deals out of 42,074 listings starting at $1,987
Used Chevrolet Camaro
468 Great Deals out of 31,602 listings starting at $1,450
Used Chevrolet C/K 3500
214 listings starting at $3,199
Used Chevrolet S-10
11 Great Deals out of 1,215 listings starting at $1,550
Used Toyota Tacoma
720 Great Deals out of 45,626 listings starting at $1,000

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.