1997 GMC Suburban Won't Start.... HELP !!!

10

Asked by Apr 10, 2011 at 09:36 PM about the 1997 GMC Suburban K1500 4WD

Question type: Maintenance & Repair

ok this started last fall. - the fuel pump went out so I changed the pump and gave it a tune up (new plugs, wires, cap and rotor) then it still would not start, so i changed the crank sensor, cam sensor, and ignition module. This still did not work, turnes out the spyder (injectors) were bad, so I changed the spyder and holy cow the truck started. Remember this was last fall. Any way once it started I took it for a test drive and all was great. I filled the tank with fresh fuel and added some seafoam. However about an hour later i noticed a huge cloud of smoke behind me and smelled oil...
Oh crap I thought I just blew my motor. So I drove it home pulled it into the garage and found that the timming cover had a crack down the side. I was so frustrated and ticked off that I just left it in the garage over the winter. So yesterday I decided I would tare it down to repalce the timming cover and while I had it opened up I would go ahead and change the timming chain amd gears too. Put it all back together today and the dang thing won't start. I checked fuel pressure and have 60psi at prime and 62psi while cranking. I checked and have 12v at each injector. I checked and have good spark. I used a noid light and test injector pulse. Everything checks good, besides it's all new parts !! - What the heck am I missing?
Read more at http://gmcowners.com/gmc-forum/showthread.php?t=17523&kcplink=1

4 Answers

85

you may have set your timing wrong

1 of 1 people found this helpful.
10

Michael - Thanks for the response. that is what I initally thought too. But I never pulled the distributor and the cam and crank marking were aligned at 6 and 12. & cylinder # 1 was TDC with rotor pointing to #1.We also put a timing light on as we cranked the engine and the marking on the harmonic balancer shows to be correct.

1 of 1 people found this helpful.
55

Do you have fuel coming out of the injectors? We had an issue where everything checked out ok but the fuse was blown of corse $199 later. Do have spark at the plugs? I had an issue where the cap got the power but was not going to the plug. And final is the motor turning over when being cranked? I had an injector fill my motor with gas and vacuum locked the motor had to pull plugs and crank got gas everywhere do not stand next to the truck when doing this.

1 of 1 people found this helpful.
20

did you ever figure it out? I have a 95 doing the same thing

2 of 2 people found this helpful.

Your Answer

Add photo

Related Questions

Suburban

Looking for a Used Suburban in your area?

CarGurus has 137 nationwide Suburban listings starting at $1,995.

ZIP:

Search GMC Suburban Questions

GMC Suburban Experts

#1 LouB
LouB
Reputation 1,320
#2 Larry Thibert
Larry Thibert
Reputation 200
#3 ShadetreeMech
ShadetreeMech
Reputation 190
View All

Related Models For Sale

Used Chevrolet Suburban
323 Great Deals out of 19,720 listings starting at $2,000
Used GMC Yukon
376 Great Deals out of 18,226 listings starting at $2,950
Used Chevrolet Tahoe
550 Great Deals out of 29,234 listings starting at $1,699
Used Ford Expedition
472 Great Deals out of 24,887 listings starting at $700
Used GMC Sierra 1500
822 Great Deals out of 68,199 listings starting at $2,484
Used Dodge Durango
274 Great Deals out of 22,704 listings starting at $1,200
Used Ford F-150
2,194 Great Deals out of 206,316 listings starting at $1,499
Used Toyota 4Runner
252 Great Deals out of 20,494 listings starting at $1,800

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.