4×4 not working correctly

5

Asked by Jan 09, 2016 at 02:37 AM about the 1999 GMC Suburban K2500 4WD

Question type: Maintenance & Repair

I have 3 wiring harnesses hanging
down below the actuator none of
which are connected to each
other. My problem is the 4×4 is not
working correctly it tries to lock in
but has a loud popping noise while
driving. It shows its in 4 hi but its
not could the wires hanging below

be the issue?

1 Answer

5

Please help anything might help!!!!

Your Answer

Add photo

Related Questions

Search GMC Suburban Questions

GMC Suburban Experts

#1 LouB
LouB
Reputation 1,290
#2 Larry Thibert
Larry Thibert
Reputation 190
#3 ShadetreeMech
ShadetreeMech
Reputation 160
View All

Related Models For Sale

Used Chevrolet Suburban
445 Great Deals out of 18,353 listings starting at $1,999
Used GMC Yukon XL
326 Great Deals out of 12,184 listings starting at $2,400
Used GMC Yukon
470 Great Deals out of 16,585 listings starting at $2,300
Used Chevrolet Tahoe
711 Great Deals out of 28,049 listings starting at $1,500
Used Ford Expedition
395 Great Deals out of 24,006 listings starting at $1,999
Used Chevrolet Silverado 1500
2,109 Great Deals out of 154,218 listings starting at $1,995
Used GMC Sierra 1500
893 Great Deals out of 62,317 listings starting at $1,395
Used Ford F-150
2,569 Great Deals out of 210,955 listings starting at $1,000
Used Ford Explorer
849 Great Deals out of 72,490 listings starting at $750
Used Ford Excursion
12 Great Deals out of 785 listings starting at $3,995
Used Cadillac Escalade
294 Great Deals out of 10,539 listings starting at $1,900
Used Dodge Durango
287 Great Deals out of 23,354 listings starting at $1,500