4×4 not working correctly

5

Asked by Jan 09, 2016 at 02:37 AM about the 1999 GMC Suburban K2500 4WD

Question type: Maintenance & Repair

I have 3 wiring harnesses hanging
down below the actuator none of
which are connected to each
other. My problem is the 4×4 is not
working correctly it tries to lock in
but has a loud popping noise while
driving. It shows its in 4 hi but its
not could the wires hanging below

be the issue?

1 Answer

5

Please help anything might help!!!!

Your Answer

GMC Suburban Experts

  • #1
    LouB
    Reputation
    1,370
  • #2
    Larry Thibert
    Reputation
    230
  • #3
    ShadetreeMech
    Reputation
    210
View All

Related Models For Sale

Used Chevrolet Suburban
331 Great Deals out of 21,730 listings starting at $1,900
Used GMC Yukon XL
243 Great Deals out of 13,569 listings starting at $1,495
Used GMC Yukon
407 Great Deals out of 21,296 listings starting at $1,495
Used Chevrolet Tahoe
665 Great Deals out of 39,392 listings starting at $1,000
Used Ford Expedition
368 Great Deals out of 19,523 listings starting at $1,295
Used Cadillac Escalade
214 Great Deals out of 11,079 listings starting at $2,000
Used GMC Sierra 1500
889 Great Deals out of 65,336 listings starting at $1,995
Used Chevrolet Silverado 1500
2,146 Great Deals out of 167,073 listings starting at $1,498
Used Ford F-150
2,316 Great Deals out of 182,093 listings starting at $1,000
Used Ford Excursion
9 Great Deals out of 782 listings starting at $2,700
Used GMC Envoy
52 Great Deals out of 2,114 listings starting at $1,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.