I have an 86 s10 blazer 4x4 with 2.8 v6 and ive replaced all sensors plugs wires cap and rotor and fuel filter its like it has a mis at low rpms or boggs down going down rd and pedal will be all way 2

Asked by Dec 23, 2014 at 03:31 AM about the 1986 Chevrolet S-10 Blazer Tahoe 4WD

Question type: Maintenance & Repair

The floor...theres no engine lights on or anything...i dunno where
to go from here...ive even cleaned the throttle body and such

1 Answer

it sound like the Cadillac converter is clogged, to check it pull to O2 senser out of the exost and start it up with it out and see if it works.

Your Answer

Add photo

Related Questions

Search Chevrolet S-10 Blazer Questions

Chevrolet S-10 Blazer Experts

#1 carGrrl
carGrrl
Reputation 1,520
#2 Cody Doud
Cody Doud
Reputation 620
#3 emtfirefighter77
emtfirefighter77
Reputation 350
View All

Related Models For Sale

Used Chevrolet S-10
8 Great Deals out of 1,351 listings starting at $1,500
Used Chevrolet Blazer
3 Great Deals out of 1,182 listings starting at $1,495
Used Ford F-150
2,133 Great Deals out of 191,041 listings starting at $290
Used Ford Mustang
724 Great Deals out of 44,324 listings starting at $1,500
Used Toyota 4Runner
227 Great Deals out of 19,594 listings starting at $2,300
Used Jeep Cherokee
366 Great Deals out of 40,282 listings starting at $1,500
Used Chevrolet Monte Carlo
16 Great Deals out of 1,434 listings starting at $1,995
Used Chevrolet Camaro
367 Great Deals out of 31,399 listings starting at $2,400

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.