i have power to my coil and coil wier to distributor but no spark from distributor to plug

Asked by Nov 01, 2015 at 07:06 PM about the 1984 Chevrolet S-10 Tahoe Extended Cab 4WD SB

Question type: General

4 Answers

69,885

Check the rotor and the coil wire and maybe replace the cap too.

1 of 1 people found this helpful.

Has it been exposed to excessive moisture? The no-cost try is take cap off and spray WD40 inside cap, or even starting fluid, allow to dry, replace rotor, if cap is aged replace that also

4 of 4 people found this helpful.

Hello Full_of_Regrets ... we were posting at the same time but at least we agree

4 of 4 people found this helpful.

no it hassent maybe now I put a new cap new rotor new coil

Your Answer

Add photo

Related Questions

S-10

Looking for a Used S-10 in your area?

CarGurus has 1,334 nationwide S-10 listings starting at $1,999.

ZIP:

Search Chevrolet S-10 Questions

Chevrolet S-10 Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 2,360
#2 John Saffrahn
John Saffrahn
Reputation 1,000
#3 Trebor66
Trebor66
Reputation 990
View All

Related Models For Sale

Used Ford Ranger
169 Great Deals out of 5,600 listings starting at $900
Used Ford F-150
2,121 Great Deals out of 193,348 listings starting at $290
Used Chevrolet Blazer
1,168 listings starting at $1,495
Used Chevrolet Camaro
351 Great Deals out of 31,326 listings starting at $2,200

Used Cars For Sale

2004 Chevrolet S-10 For Sale
55 listings starting at $2,695
2003 Chevrolet S-10 For Sale
308 listings starting at $1,999
2002 Chevrolet S-10 For Sale
4 Great Deals out of 210 listings starting at $2,880
2001 Chevrolet S-10 For Sale
166 listings starting at $2,300

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.