Why doesn't temp. guage work?

Asked by Nov 05, 2013 at 07:38 PM about the 1984 Ford Ranger STD Standard Cab 4WD SB

Question type: Maintenance & Repair

Temp. gauge does not work put new sending unit in , still not working. Ran test light from ground to sending unit wire Test light goes on and off and gauge goes to hot, any solutions?

1 Answer

98,445

Gauge seems to work with your tests, did you get the wrong sender from the parts store? There is one for the ECM and one for the gauge, there were a few Rangers made that only had a light for overheat so make sure you have the sender for a gauge.

Your Answer

Ford Ranger Experts

  • #1
    tennisshoes
    Reputation
    1,320
  • #2
    F_O_R
    Reputation
    830
  • #3
    Tracy Hooks
    Reputation
    820
View All

Related Models For Sale

Used Ford F-150
2,232 Great Deals out of 183,000 listings starting at $1,500
Used Chevrolet S-10
7 Great Deals out of 1,283 listings starting at $1,800
Used Ford Mustang
764 Great Deals out of 42,666 listings starting at $1,300

Used Cars For Sale

2011 Ford Ranger For Sale
31 Great Deals out of 808 listings starting at $4,500
2010 Ford Ranger For Sale
21 Great Deals out of 498 listings starting at $4,500
2009 Ford Ranger For Sale
19 Great Deals out of 356 listings starting at $3,500
2008 Ford Ranger For Sale
24 Great Deals out of 416 listings starting at $2,999
2007 Ford Ranger For Sale
16 Great Deals out of 297 listings starting at $1,900

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.