Toyota Van missing will not idle for more than a few seconds

Asked by Jul 03, 2013 at 04:53 PM about the 1989 Toyota Van LE 4WD Passenger Van

Question type: Maintenance & Repair

I have a 1989 Toyota Van Wagon LE. I bought the van about a year ago and it has sat
since then. Prior to my buying it the previous owner had done some mudding with it so
the bottom has a lot of hardened mud. Something may have come loose or been jarred
too much from the off-roading that could be causing my problem but I don't know. He said
it ran fine before that so I'm guessing it has something to do with it. When I finally go
around to messing with it in the past few days the fuel pump had gone out so I replaced it
with a smaller one from a 4Runner. The van starts and drives but it is missing pretty bad
and will not idle for more than a few seconds without needing you to push the gas. I have
replaced all of the spark plugs and still nothing changes. I have a fuel pressure gauge but
need some help finding where to splice in. Anyone got any ideas on what might be
causing my problem? The van is a 4x4 5 speed.

1 Answer

254,705

Did you put some fuel additive or new fuel in it? You might have water/condensation in the fuel.

Your Answer

Toyota Van Experts

  • #1
    Mike Kohunui
    Reputation
    20
  • #1
    paulsimonkenya
    Reputation
    20
  • #3
    COMETGUY61
    Reputation
    10
View All

Related Models For Sale

Used Toyota Camry
1,032 Great Deals out of 73,122 listings starting at $295
Used Toyota 4Runner
279 Great Deals out of 21,720 listings starting at $1,750
Used Toyota Corolla
879 Great Deals out of 56,333 listings starting at $1,488
Used Toyota Land Cruiser
7 Great Deals out of 1,001 listings starting at $4,850

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.