I just bought a used 1984 944 5spd. Everything was running fine until one day I shut the car off in the driveway and now when I try to start it it just gives a loud click and everything powers down. If I let it sit for awhile then put the key in the ignition and turn it it to accessories I have power to everything but as soon as I try to start it theres the loud click and everything powers down again. Any suggestions

Asked by Apr 11, 2015 at 10:31 AM about the 1984 Porsche 944 STD Hatchback

Question type: Maintenance & Repair

2 Answers

35

have you checked the starter? and your battery connections? sometimes loose connections will still give power for accessories, but click and have nothing when you try to start.

2,050

Check the state of charge in your battery by hooking it up to a charger. If low, charge about an hour at 8-10 amps. If the battery is old it won't hold the charge for long. As Dean said above, check your connections, especially the ground connections, particularly the one on the firewall up top near the battery itself. Use copper never-seize on the ground connections if they are in bad shape. Good Luck

Your Answer

Porsche 944 Experts

  • #1
    Robert DeNicola
    Reputation
    250
  • #2
    Adam Morgan
    Reputation
    220
  • #3
    Stephen Smith
    Reputation
    160
View All

Related Models For Sale

Used Porsche 911
120 Great Deals out of 5,106 listings starting at $7,988
Used Porsche 928
36 listings
Used Chevrolet Corvette
182 Great Deals out of 17,470 listings starting at $3,000
Used Porsche 924
12 listings
Used Ford Mustang
608 Great Deals out of 39,402 listings starting at $1,895
Used BMW 3 Series
1,158 Great Deals out of 32,871 listings starting at $1,200
Used Chevrolet Camaro
468 Great Deals out of 31,602 listings starting at $1,450

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.