I just bought a used 1984 944 5spd. Everything was running fine until one day I shut the car off in the driveway and now when I try to start it it just gives a loud click and everything powers down. If I let it sit for awhile then put the key in the ignition and turn it it to accessories I have power to everything but as soon as I try to start it theres the loud click and everything powers down again. Any suggestions

Asked by Apr 11, 2015 at 10:31 AM about the 1984 Porsche 944 STD Hatchback

Question type: Maintenance & Repair

2 Answers

35

have you checked the starter? and your battery connections? sometimes loose connections will still give power for accessories, but click and have nothing when you try to start.

1,530

Check the state of charge in your battery by hooking it up to a charger. If low, charge about an hour at 8-10 amps. If the battery is old it won't hold the charge for long. As Dean said above, check your connections, especially the ground connections, particularly the one on the firewall up top near the battery itself. Use copper never-seize on the ground connections if they are in bad shape. Good Luck

Your Answer

Add photo

Related Questions

Search Porsche 944 Questions

UK Questions

Are you a UK consumer? CarGurus now has a discussion forum in the UK.

Porsche 944 Experts

#1 Robert DeNicola
Robert DeNicola
Reputation 240
#2 Adam Morgan
Adam Morgan
Reputation 190
#3 Stephen Smith
Stephen Smith
Reputation 140
View All

Related Models For Sale

Used Porsche 911
131 Great Deals out of 4,461 listings starting at $8,901
Used Porsche 928
33 listings
Used Porsche 924
12 listings
Used Chevrolet Corvette
282 Great Deals out of 20,456 listings starting at $3,688
Used BMW 3 Series
1,450 Great Deals out of 38,330 listings starting at $1,495
Used Ford Mustang
562 Great Deals out of 42,506 listings starting at $1,699
Used Chevrolet Camaro
438 Great Deals out of 40,559 listings starting at $3,500
Used BMW 5 Series
596 Great Deals out of 15,323 listings starting at $2,495