95 avenger runs great when cold rough when hot

Asked by Mar 18, 2010 at 09:13 AM about the 1995 Dodge Avenger 2 Dr ES Coupe

Question type: Maintenance & Repair

when i start the car after it sits a while it runs great after i drive it and it gets up to tempeture it runs rough i changed the plugs and wires not sure what else to do please help

1 Answer

sounds like an ignition problem. sounds like the timing is off but im no mechanic

Your Answer

Add photo

Related Questions

Search Dodge Avenger Questions

Dodge Avenger Experts

#1 Tom Demyan
Tom Demyan
Reputation 730
#2 Janis Jackson
Janis Jackson
Reputation 380
#3 thedoctor
thedoctor
Reputation 350
View All

Related Models For Sale

Used Honda Accord
1,029 Great Deals out of 68,841 listings starting at $1,000
Used Ford Mustang
689 Great Deals out of 44,974 listings starting at $750
Used Nissan Altima
1,271 Great Deals out of 75,675 listings starting at $1,695
Used Chevrolet Impala
619 Great Deals out of 35,468 listings starting at $899
Used Chevrolet Camaro
350 Great Deals out of 31,314 listings starting at $2,500

Used Cars For Sale

2014 Dodge Avenger For Sale
46 Great Deals out of 1,091 listings starting at $5,995
2013 Dodge Avenger For Sale
37 Great Deals out of 1,308 listings starting at $4,900
2012 Dodge Avenger For Sale
18 Great Deals out of 819 listings starting at $4,250
2011 Dodge Avenger For Sale
9 Great Deals out of 387 listings starting at $3,800
2010 Dodge Avenger For Sale
9 Great Deals out of 413 listings starting at $3,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.