I put a new IAC in and it still stalls in idle occasional and still idle high during start up .

Asked by Apr 14, 2015 at 09:17 PM about the 1996 Dodge Avenger 2 Dr ES Coupe

Question type: General

2 Answers


Did you clean your throttle body and MAF? That might help. Check youtube on how to do it. Also check for vacuum leaks?


Don't forget to reset the ECM after your repair so the ECM can relearn the with the new part.

Your Answer

Dodge Avenger Experts

  • #1
    Tom Demyan
  • #2
    Janis Jackson
  • #3
View All

Related Models For Sale

Used Chevrolet Malibu
664 Great Deals out of 48,938 listings starting at $1,500
Used Nissan Altima
820 Great Deals out of 68,383 listings starting at $750
Used Chevrolet Impala
379 Great Deals out of 27,771 listings starting at $1,499
Used Honda Accord
592 Great Deals out of 92,752 listings starting at $1,495
Used Ford Mustang
317 Great Deals out of 38,894 listings starting at $1,995
Used Chevrolet Camaro
267 Great Deals out of 30,511 listings starting at $4,200

Used Cars For Sale

2014 Dodge Avenger For Sale
16 Great Deals out of 770 listings starting at $4,500
2013 Dodge Avenger For Sale
14 Great Deals out of 1,024 listings starting at $4,100
2012 Dodge Avenger For Sale
9 Great Deals out of 611 listings starting at $3,700
2011 Dodge Avenger For Sale
10 Great Deals out of 261 listings starting at $3,200
2010 Dodge Avenger For Sale
254 listings starting at $2,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.