2002 dodge neon sputtering feels like wants to die and takes off real slow. when reversing its real bad sputtering and when stopped at light it starts ideling real bad snd sputtering again

40

Asked by Oct 16, 2012 at 11:19 AM about the 2002 Dodge Neon 4 Dr SE Sedan

Question type: Maintenance & Repair

39 Answers

1,645

could be a lot of things, sounds to be missing for sure. i'd start with spark plugs, spark plug wires, and a new coil pack. if none of those seem to help, have a shop do a compression test on all cylinders.

7 of 7 people found this helpful.
435

What he said ^ more than likely its plugs, wires, and coil.

2 of 2 people found this helpful.
10,675

I would assume you have a check engine light. Have you had the code pulled yet? It will help lead you in the general direction... I have to agree with the above though. Most likely just needs a tune-up.

1 of 1 people found this helpful.
40

I have no engine light on went to get codes pulled anyways and not a single code came up and the gas mileage is horrible.

2 of 2 people found this helpful.
9,025

no check engine light seems strange, seems something would be a miss...hard to say with out seeing it, experiencing it, have you got it resolved yet?

1 of 1 people found this helpful.
40

no have not gotten it fixed as of yet ready to get a can of can and a match.....

1 of 1 people found this helpful.
40

can of gas i meant to say

9,025

ahaha, I know the frustration....have the positive battery cable off of the battery, and touch the cable to the negative, (nothing will happen, it is safe), and leave it there for 30 seconds or so, that will completely reset all the computers in the car. if one is having a "glitch", or issue, this should free it up., No check engine light means that every single computer is working properly, or the light was removed previously, either way, a severe mechanical failure such as this, should show up...personally thinking a vacuum leak, or something similiar, may i ask what state you are in?

40

i live in cheyenne wyoming what about you if you dont mind my asking

1 of 1 people found this helpful.
9,025

Connecticut...too far a distance, lol, too many computers to guess at. which is why the reset would help so much.try that and let me know if anything changes.

1,645

since you threw gas mileage in there, it could be the upstream o2 sensor as well.

9,025

yes, but justin it is possible to have a mechanical failure, which is a problem, not picked up by any computer system, an 02 sensor, is still a sensor, and would throw a code...

25

You Most Likely Need A Tune up But You Should Check For A Vacumm Leak. It Sounds Like Nothing But You Would Be Surprise What A Simple Vacumm Leak Would Do to A Neon

2 of 2 people found this helpful.
7,115

Anybody think either maybe timing is off or there is a burnt valve? it is possible for an injector to have an irratic spray patern and burn a valve seat.

1 of 1 people found this helpful.
10,675

Honestly Chris.. It really could be anything. Anything from bad gas to a catastrophic mechanical failure. Seriously though, 9 times out of ten if you car just starts running rough, it is usually caused due to the lack of maintenance (ie: tune up needed, cracked vacuum lines (vacuum leak in general), clogged cat, etc).

20

My neon does the same. At first it had codes for a misfire so I replaced to coil, plugs, and the wires. Then it started reading bad camshaft position sensor, so I replaced that. Now I have no codes but it still runs and idles rough.

2 of 2 people found this helpful.

They had to put another ignition switch that's when the problem started.my radio works sometime

ive been told by 4 ppl its the TPS sensor. i havent chaged it yet but i got the same car and same problem. cpu said random misfires only on 3 different readers.

hmm having the same issue the CEL came on said it was cam sensor replaced it reset engine light, problem improved. will try battery reset.

tps sensor should still throw a code.

I have a 2001 neon was doing the same thing no power and no code. I changed spark plugs and air filter and plug wires and now its running fine again. hope this helps someone...

20

Anyone try the coolant temp sensor?

1 of 1 people found this helpful.
20

Stephen did that problem got better but in a few days went back to doing what it was doing.

1 of 1 people found this helpful.
30

I have manuel 05 neon 2.0L . Sometimes runs great, others like it's trash!! For instance it fires up nice, sounds A1 Ill go 4_5 stoplights.then when taking off, it does not want to go.reving up it sounds like the RPMs are dissing but shows that they never exceed 2xxx-25xxx it takes off slowly like it wants to die. Putting and chugging. Temp normal. It's got oil, gas, water.. also throws a check engine light. Only 82xxx original miles.. Can anyone help! If not I'm calling insurance and bumping coverage to full..lol

3 of 3 people found this helpful.

@tom have you gotten it fix.. My 01 is doing the same.

20

i just got a 2003 dodge neon it runs smooth gas miliage not so good but it idles rough there is a poppin goes on with it done changed the spark plugs n wires hope they done right but wen idling r taking off push gas it stalls pops n wont budge then it takes off its dangerous n embarrassing

2 of 2 people found this helpful.
20

when it runs bad, and then sluggish from a stop. turn off your AC and it seems to run fine but we live in the High desert and its been really HOT so I turn AC on while driving and then when I come to a stop and before accelerating the AC is Off, and when I'm moving at least 20-30 AC goes back on...Sounds Crazy but it works... anyway I have changed O2, Spark Plugs ,Air filter and Now I will change Wires and Coil see what happens.. take care

2 of 2 people found this helpful.

I have run acrost this problem in all makes and modles 75% of the time it is the cadiladic converter 25% it's a sensor and or timing belt slipage over time the tensioner on the timing belt streched it just enough to throw it off a half tooth hope this helps all of you

I have a 05 Dodge Neon doing the same thing and I change the camshaft sensor TPS cool coil pack spark plugs spark plug wires and cannot find a vacuum leak but it is still running rough

10

Don't forget the PCV valve, it has a lot to do with idle and fresh air into crank.

1 of 1 people found this helpful.
20

I have a 2003 dodge neon sxt and we just had the camshaft position sensor and crankshaft position sensor replaced. When accelerating it misfires and loses power but once warmed up it is perfectly fine. Any possible answers??

2 of 2 people found this helpful.

I have a 2002 dodge neon want crank no power to spark plugs nor fuel pump I change the crank shaft sensor and nothing. What else can I do

Has anyone corrected this runs good/then stalls at red light or slow speed by changing injector plugs?

Has anyone solved this running fine then stalling at traffic light or slow traffic by changing fuel injectors?

I had almost all these issues. The crank no start you meed to replace the cam AND crank sensor immediately after you meed to disconnect battery for five minites than tey again. As for the rough iddle at a stop but goes away in neutral or park you have a bad evap module. Located on rear passenger side behind tire. I tried new plugs wires pcv valve new throttle body and finally the new module fixed my problem... Hope this helps!

It could be something totally different my car is doing the same thing tuned up and everything is done but it's an intake problem air flu is not flowing correctly still trying to work out the Kinks

After replacing several parts I got the 2005 Dodge Neon fixed. I replaced the leak detecton pump to right of fuel tank behind the right rear tire. Here is the website of the part purchased. https://www.partsgeek.com/h1kr397-dodge-neon-leak-detection-pump.html?utm_source=bing&utm_medium=ff&utm_content=MP&utm_campaign=PartsGeek+Bing&gb=pp&utm_term=05+2005+dodge+neon+leak+detection+pump+-+dorman+leak+detection+pump&ad=11620898016

I have a 2005 Dodge Neon SXT and it's doing the same thing. At stop lights and signs the RPM goes down to 700rpm and the engine sputters and acts like it wants to cut off. It's worse with the A/C on, so I put it in neutral. It's still there just not as bad. NO CODES using the 3 key turns for the dash and with an OBDII reader. Also when driving up an incline around 40mph it feels like the transmission is slipping. On even ground at 40mph fine. I don't want to throw parts and money away.

I cannot say the fix we used will work on our car but stepson, his father and I tried several things before we replaced the leak detection pump behind the right rear wheel to right of gas tank. See part on my comment above.

Your Answer

Neon

Looking for a Used Neon in your area?

CarGurus has 585 nationwide Neon listings and the tools to find you a great deal.

ZIP:

Dodge Neon Experts

  • #1
    Justin Gilmore
    Reputation
    1,400
  • #2
    Matt Thibault
    Reputation
    1,000
  • #3
    Scott Goodyear
    Reputation
    860
View All

Related Models For Sale

Used Dodge Neon SRT-4
4 Great Deals out of 30 listings starting at $1,998
Used Honda Civic
790 Great Deals out of 60,728 listings starting at $950
Used Ford Mustang
600 Great Deals out of 39,164 listings starting at $1,895
Used Ford Focus
808 Great Deals out of 61,922 listings starting at $900
Used Toyota Corolla
952 Great Deals out of 64,765 listings starting at $1,850
Used Dodge Stratus
743 listings starting at $2,900
Used Honda Accord
1,098 Great Deals out of 73,069 listings starting at $1,100
Used Mitsubishi Lancer Evolution
10 Great Deals out of 577 listings starting at $12,999
Used Chevrolet Malibu
1,132 Great Deals out of 62,114 listings starting at $880

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.