I replaced the throttle body and the accelerator pedal position sensor and car still idle high and only drives 15mph, what is the problem?

Asked by Aug 02, 2014 at 10:57 PM about the 2005 Dodge Magnum SE

Question type: Maintenance & Repair

need to know what the problem could be.

1 Answer

4,825

Check the MAF? Are you getting any codes, maybe the car has gone into "limp" mode. Why did you change the throttle body and pedal sensor anyhow, what was the issue before you did that?

1 of 1 people found this helpful.

Your Answer

Dodge Magnum Experts

  • #1
    Norm Davis
    Reputation
    350
  • #2
    Miguel Carrasco
    Reputation
    340
  • #3
    XS22L9R
    Reputation
    280
View All

Related Models For Sale

Used Dodge Charger
377 Great Deals out of 33,510 listings starting at $2,000
Used Chrysler 300
349 Great Deals out of 20,652 listings starting at $900
Used Dodge Durango
312 Great Deals out of 25,680 listings starting at $1,500
Used Ford Mustang
607 Great Deals out of 39,015 listings starting at $1,500
Used Chevrolet Impala
563 Great Deals out of 36,766 listings starting at $990
Used Dodge Ram 1500
414 Great Deals out of 11,104 listings starting at $1,499
Used Chevrolet Tahoe
857 Great Deals out of 44,892 listings starting at $1,980
Used Jeep Grand Cherokee
1,047 Great Deals out of 84,354 listings starting at $1,200
Used Ford F-150
3,205 Great Deals out of 239,472 listings starting at $1,300
Used Nissan Maxima
339 Great Deals out of 23,701 listings starting at $1,200
Used Cadillac CTS
281 Great Deals out of 11,151 listings starting at $2,950
Used Chevrolet Monte Carlo
9 Great Deals out of 1,237 listings starting at $1,488
Used Chevrolet Silverado 1500
2,706 Great Deals out of 196,455 listings starting at $699

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.