I replaced the throttle body and the accelerator pedal position sensor and car still idle high and only drives 15mph, what is the problem?

Asked by Aug 02, 2014 at 10:57 PM about the 2005 Dodge Magnum SE

Question type: Maintenance & Repair

need to know what the problem could be.

1 Answer

4,325

Check the MAF? Are you getting any codes, maybe the car has gone into "limp" mode. Why did you change the throttle body and pedal sensor anyhow, what was the issue before you did that?

1 out of 1 people think this is helpful.

Your Answer

Add photo

Related Questions

Search Dodge Magnum Questions

Dodge Magnum Experts

#1 Norm Davis
Norm Davis
Reputation 330
#2 XS22L9R
XS22L9R
Reputation 270
#3 Miguel Carrasco
Miguel Carrasco
Reputation 210
View All

Related Models For Sale

Used Dodge Charger
535 Great Deals out of 29,306 listings starting at $2,343
Used Chrysler 300
517 Great Deals out of 21,195 listings starting at $1,500
Used Dodge Durango
480 Great Deals out of 23,346 listings starting at $950
Used Chevrolet Impala
998 Great Deals out of 36,594 listings starting at $1,800
Used Chevrolet Tahoe
1,100 Great Deals out of 31,962 listings starting at $1,495
Used Dodge Ram 1500
551 Great Deals out of 13,019 listings starting at $1,800
Used Ford Mustang
717 Great Deals out of 38,862 listings starting at $1,999
Used Jeep Grand Cherokee
1,164 Great Deals out of 70,567 listings starting at $495
Used Chevrolet Monte Carlo
16 Great Deals out of 1,737 listings starting at $1,695
Used Cadillac CTS
440 Great Deals out of 13,100 listings starting at $1,295
Used Ford F-150
3,447 Great Deals out of 206,326 listings starting at $1,273
Used BMW 7 Series
179 Great Deals out of 5,870 listings starting at $1,600
Used Nissan Maxima
500 Great Deals out of 25,223 listings starting at $1,500