Chrystler LHS 2001 - Vehicle has a new Crank position sensor and fuel pump - vehicle still stalls with a no start condition. 30min later it starts? Whats up?

Asked by Feb 08, 2015 at 06:00 PM about the 2001 Chrysler LHS 4 Dr STD Sedan

Question type: Maintenance & Repair

Just replaced the Fuel pump and Cam Position sensor.   Vehicle stalled on the high way.  
After 1hr vehicle would start again...   thought the problem was related to tired fuel pump
or possibly an overheated cam sensor.  Replaced both - have the same problem... What
else would cause a stall and no start condition like this?

2 Answers

770

well since you replaced the cam P.sensor did you replace the crank sensor also ?

11,560

had this happen on a chevy once, and it ended up being a bad injector. once it cooled it would start. also, the computer didn't throw any codes for it. might have your injectors tested.

Your Answer

Add photo

Related Questions

Search Chrysler LHS Questions

Chrysler LHS Experts

#1 Lavinia Raven
Lavinia Raven
Reputation 100
#1 Angel Izor
Angel Izor
Reputation 100
#3 Paul Norenberg
Paul Norenberg
Reputation 90
View All

Related Models For Sale

Used Chrysler 300M
230 listings
Used Lincoln Town Car
36 Great Deals out of 1,808 listings starting at $1,495
Used Chevrolet Impala
554 Great Deals out of 35,454 listings starting at $899
Used Ford Expedition
431 Great Deals out of 23,882 listings starting at $1,500
Used Pontiac Grand Prix
25 Great Deals out of 2,829 listings starting at $1,850
Used Chevrolet Malibu
1,118 Great Deals out of 80,272 listings starting at $2,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.