sensor

Asked by May 09, 2012 at 08:42 PM about the 2004 Chrysler 300M Special

Question type: Maintenance & Repair

I had a sensor replaced on the trans. Still have a problem. Engine light stays on, in park reving to 3000rpm it feels like something misfiring. Used to do this to me driving on the highway. Would be driving and all of a sudden the car would hardly move. Had to pull over and shut it off for about 5 minutes. Restart and it was fine, but engine light always on.

1 Answer

12,665

Couple things, check your vacuum system and determine what the code is. There is a vacuum diagnostic check you can do. It will tell you much about your engine. Repost if interested I'll put it on here later today ....

1 out of 1 people think this is helpful.

Your Answer

Add photo

Related Questions

Search Chrysler 300M Questions

Chrysler 300M Experts

#1 aztec626bf
aztec626bf
Reputation 400
#1 Jearod Leet
Jearod Leet
Reputation 400
#3 Felix Melendez
Felix Melendez
Reputation 390
View All

Related Models For Sale

Used Chrysler 300
341 Great Deals out of 20,505 listings starting at $1,000
Used Chevrolet Impala
544 Great Deals out of 28,509 listings starting at $700
Used Ford Mustang
333 Great Deals out of 45,576 listings starting at $2,000
Used Honda Accord
679 Great Deals out of 82,247 listings starting at $500
Used Jeep Grand Cherokee
846 Great Deals out of 69,765 listings starting at $700
Used Ford F-150
2,403 Great Deals out of 210,248 listings starting at $895
Used Chevrolet Silverado 1500
1,983 Great Deals out of 160,213 listings starting at $1,995
Used Cadillac CTS
240 Great Deals out of 11,574 listings starting at $1,599
Used Dodge Durango
245 Great Deals out of 22,761 listings starting at $1,499
Used Chevrolet Tahoe
611 Great Deals out of 27,552 listings starting at $600
Used Jeep Wrangler
285 Great Deals out of 18,941 listings starting at $3,295