sensor

Asked by May 09, 2012 at 08:42 PM about the 2004 Chrysler 300M Special

Question type: Maintenance & Repair

I had a sensor replaced on the trans. Still have a problem. Engine light stays on, in park reving to 3000rpm it feels like something misfiring. Used to do this to me driving on the highway. Would be driving and all of a sudden the car would hardly move. Had to pull over and shut it off for about 5 minutes. Restart and it was fine, but engine light always on.

1 Answer

13,115

Couple things, check your vacuum system and determine what the code is. There is a vacuum diagnostic check you can do. It will tell you much about your engine. Repost if interested I'll put it on here later today ....

1 of 1 people found this helpful.

Your Answer

Chrysler 300M Experts

  • #1
    Jearod Leet
    Reputation
    440
  • #2
    Felix Melendez
    Reputation
    410
  • #3
    aztec626bf
    Reputation
    400
View All

Related Models For Sale

Used Chrysler 300
363 Great Deals out of 16,655 listings starting at $1,000
Used Ford Mustang
744 Great Deals out of 42,177 listings starting at $1,300
Used Cadillac CTS
277 Great Deals out of 10,257 listings starting at $1,500
Used Nissan Maxima
349 Great Deals out of 23,418 listings starting at $1,550
Used Jeep Grand Cherokee
869 Great Deals out of 70,866 listings starting at $995
Used Chevrolet Impala
575 Great Deals out of 34,588 listings starting at $1,250
Used Ford F-150
2,116 Great Deals out of 181,536 listings starting at $1,000
Used Honda Accord
1,037 Great Deals out of 61,333 listings starting at $999
Used Dodge Durango
269 Great Deals out of 20,209 listings starting at $999
Used Chevrolet Corvette
242 Great Deals out of 22,068 listings starting at $2,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.