I just bought a 94 Fleetwood. Since I've had it I've replaced the radiator. But my fans aren't working. I've tested both motors, and they work. Ok. So not the motors..where do i go from there?

Asked by Nov 06, 2015 at 01:19 PM about the 1994 Cadillac Fleetwood Base Sedan

Question type: Maintenance & Repair

6 Answers

46,825

Check the temperature sensor at the radiator. Make sure it is hooked up and working. Also check the fuse for the fans.

Isn't that on the tank

46,825

It will be on the radiator or on the engine near the thermostat. I am not sure what tank you are referring to.

Coolant Reservoir tank. I have the elc water pump. There's no sensor on the radiator

I think its in the wiring from the relay

46,825

The temperature sensor has to be on an area that gets hot from coolant after it has left the engine. It won't be on a over flow tank.

Your Answer

Add photo

Related Questions

Fleetwood

Looking for a Used Fleetwood in your area?

CarGurus has 125 nationwide Fleetwood listings and the tools to find you a great deal.

ZIP:

Search Cadillac Fleetwood Questions

Cadillac Fleetwood Experts

#1 Rowefast
Rowefast
Reputation 640
#2 Justin Hatfield
Justin Hatfield
Reputation 220
#3 chassy
chassy
Reputation 120
View All

Related Models For Sale

Used Cadillac DeVille
6 Great Deals out of 1,954 listings starting at $1,750
Used Cadillac Eldorado
424 listings starting at $2,250
Used Chevrolet Impala
795 Great Deals out of 34,381 listings starting at $799
Used Lincoln Town Car
30 Great Deals out of 2,076 listings starting at $1,995
Used Chevrolet Caprice
175 listings starting at $13,998
Used Lincoln Continental
3,713 listings starting at $42,294
Used Jaguar XJ-Series
62 Great Deals out of 2,374 listings starting at $1,990
Used Chevrolet Camaro
282 Great Deals out of 38,308 listings starting at $1,250
Used BMW 7 Series
168 Great Deals out of 5,947 listings starting at $3,400