I just bought a 94 Fleetwood. Since I've had it I've replaced the radiator. But my fans aren't working. I've tested both motors, and they work. Ok. So not the motors..where do i go from there?

Asked by Nov 06, 2015 at 01:19 PM about the 1994 Cadillac Fleetwood Base Sedan

Question type: Maintenance & Repair

6 Answers

52,125

Check the temperature sensor at the radiator. Make sure it is hooked up and working. Also check the fuse for the fans.

Isn't that on the tank

52,125

It will be on the radiator or on the engine near the thermostat. I am not sure what tank you are referring to.

Coolant Reservoir tank. I have the elc water pump. There's no sensor on the radiator

I think its in the wiring from the relay

52,125

The temperature sensor has to be on an area that gets hot from coolant after it has left the engine. It won't be on a over flow tank.

Your Answer

Add photo

Related Questions

Fleetwood

Looking for a Used Fleetwood in your area?

CarGurus has 118 nationwide Fleetwood listings and the tools to find you a great deal.

ZIP:

Search Cadillac Fleetwood Questions

Cadillac Fleetwood Experts

#1 Rowefast
Rowefast
Reputation 640
#2 Justin Hatfield
Justin Hatfield
Reputation 220
#3 chassy
chassy
Reputation 120
View All

Related Models For Sale

Used Cadillac DeVille
9 Great Deals out of 1,587 listings starting at $1,995
Used Cadillac Eldorado
379 listings starting at $995
Used Lincoln Town Car
31 Great Deals out of 1,818 listings starting at $1,650
Used Chevrolet Impala
588 Great Deals out of 29,008 listings starting at $1,300
Used Chevrolet Caprice
145 listings starting at $11,995
Used Chevrolet Corvette
107 Great Deals out of 20,756 listings starting at $3,499
Used Lincoln Continental
3,786 listings starting at $42,995
Used Chevrolet Monte Carlo
8 Great Deals out of 1,402 listings starting at $2,500
Used Chevrolet Tahoe
629 Great Deals out of 27,855 listings starting at $600